[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Compiling lilypond on a Mac

From: Trevor Bača
Subject: Re: Compiling lilypond on a Mac
Date: Fri, 28 Sep 2007 11:14:27 -0500

On 9/21/07, Jared Grubb <address@hidden> wrote:
> I am trying to compile Lilypond devel branches (tried 28 to 33) and I
> *finally* got them to compile, but I cannot get them to pass the
> test-baseline set:
> $ ./configure --with-ncsb-dir=/sw/share/ghostscript/fonts
> $ make
> $ make test-baseline
>  (.....)
> Reading out-test/collated-files.tely...
> Dissecting...
> Writing snippets...
> Processing...
> Running lilypond...GNU LilyPond 2.11.33
> command failed:  ...../lilypond .....(assume you know this stuff)....
> Child returned 1
> make[3]: *** [out-test/collated-files.texi] Error 1
> make[2]: *** [local-test] Error 2
> make[1]: *** [test] Error 2
> make: *** [test-baseline] Error 2
> $
> I tried 2.11.28, 2.11.30, 2.11.32, 2.11.33 and get similar errors. The
> latest stable release passes all the tests just fine. Any idea what I
> have done wrong?
> Jared
> ---------------------------------------------------------
> (by the way... here is a step-by-step on what I had to do to get
> Lilypond to compile on Mac... it was quite a bit of work, so I
> documented it step-by-step in order to help anyone else who attempts
> to do this! It also might give some insight into something I did wrong?)
> ====================================================
> NOTE 1: I had to use Fink, because there is an issue in GMP on Mac-intels,
> and I tried all sorts of work-arounds but could NOT get guile to compile.
> Therefore, I decided to do all the building from inside Fink.
> NOTE 2: Always try to build/install from source. Fink didn't find the
> dependencies on some of the packages right, so some of the source builds
> failed for me (I will mark those). Later, we will go back through and
> retry it once we get through the list once, and it should work then.
> NOTE 3: This is a list of things that must be done from a fresh Mac OS/X
> install. Make sure to install XCode and X11 tools from the Mac disks.
> -1) Get python 2.5.
> 0) download and install fink. Then, make sure to "selfupdate". The package
> list from the initial fink install is too out-dated and some of the
> packages wont show up (like guile18)
> 1) guile18, guile18-dev, guile18-doc, guile-libs, guile18-shlibs from source
> 2) bison from source
> 3) pkgconfig from source
> 4) autoconf from source
> 5) freetype2 from source
> 6) You now should install fontconfig2. Unfortunately, the fink package
> did not build all the tools (specifically fc-match). So instead, download
> 2.4.1 from the fontconfig2 website, and build and install from that source,
> NOT fink.
> 7) fontforge from source (the binary version is very old). I got an error in
> the build process that it could not find libpng12.dylib. The library search
> path was not working right, and I couldnt' figure out how to get the right
> path in. So, I cheated with a
> "sudo ln -s /sw/lib/libpng12.dylib /usr/local/lib/libpng12.dylib"
> and the build worked perfect.
> 8) gd2 from binary (this one would not compile from source)
> 9) t1lib5 from binary (this one wouldn't compile from source)
> At this point, I tried to get mftrace to install, but it required tetex,
> which would not compile. From a forum post, I learned that my X11 config
> was broken. So, I had to do a reinstall of X11User.pkg and X11SDK.pkg from
> the Mac system disc. Then, it worked!
> 10) mftrace from source (bin is too old)
> 11) pango1-xft2-ft219, pango1-xft2-ft219-dev, pango1-xft2-ft219-shlibs
> from source
> 12) glib2, glib2-dev, glib2-shlibs from source
> If you installed any of the packages above from binary, go back now and
> install from source. In my trials, lilypond would not compile right, but
> after I rebuilt all the above from source, it finally compiled just fine!
> Now, I found a nice forum post from lilypond list archives and set the
> following environment variables:
> * export  PKG_CONFIG_PATH=/sw/lib/fontconfig2/lib/pkgconfig:
> /sw/lib/freetype219/lib/pkgconfig:/sw/lib/pango-ft219/lib/pkgconfig:
> * export GUILE_CONFIG=guile-1.8-config
> * export PYTHON=/sw/bin/python2.5
> * export GUILE=/sw/bin/guile-1.8
> And, now, time to build lilypond. Note the option for configure; without
> this option, configure will find TTF files instead of the PFB files....
> * ./configure --with-ncsb-dir=/sw/share/ghostscript/fonts
> * make

Hi Jared,

This is very, very cool. I haven't built since I was on a (non-Intel)
G4 under OS X. And I've been meaning to get around to building on my
Intel OS X box for a while now. So this should really help.

So did you get past the baseline tests?


Trevor Bača

reply via email to

[Prev in Thread] Current Thread [Next in Thread]