[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with 2.13.30?

From: Trevor Daniels
Subject: Re: Problem with 2.13.30?
Date: Sun, 15 Aug 2010 09:57:54 +0100

Patrick McCarty wrote Sunday, August 15, 2010 7:27 AM
On Sat, Aug 14, 2010 at 5:23 PM, Patrick McCarty <address@hidden> wrote:
On Sat, Aug 14, 2010 at 4:10 PM, Trevor Daniels <address@hidden> wrote:
The mingw binary of 2.13.30 gives the following error
under Vista on my system:

Running lilypond-book
Traceback (most recent call last):
File "c:/program files/lilypond/usr/bin/", line 86, in ?
import book_base as BookBase
File "out/", line 4, in ?
File "out/", line 9, in ?
File "c:\Program Files\LilyPond\usr\lib\python2.4\", line 352,
import msvcrt
ImportError: No module named msvcrt
Lilypond-book returned code 1

Could someone else please try this to see if this is a
problem with the release or my system.

I can reproduce the problem with Wine, running the following:

$ wine python.exe

I've never tried this before, so I don't know whether or not this
worked with 2.11.29 or earlier.

One further note:

This could be related to Jan's recent changes to the MinGW Python
build in GUB.  Something related to "msvcrt" was added here:

Hhm, looks suspicious, but I'm out of my depth here.

Earlier recent GUB releases gave a different problem which I
reported to the bug list on 7 July:

Graham thought this might have been caused by Reinhold's refactoring
of lilypond-book.

For my LilyPond work since then I've used lilypond-book from 2.13.14,
which still works fine.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]