[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: utf-8-strings

From: David Kastrup
Subject: Re: utf-8-strings
Date: Mon, 09 Jul 2012 00:50:28 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.1.50 (gnu/linux)

David Nalesnik <address@hidden> writes:

> On Sun, Jul 8, 2012 at 8:00 AM, David Kastrup <address@hidden> wrote:
>     Thomas Morley <address@hidden> writes:
>     > 2012/7/8 David Nalesnik <address@hidden>:
>     >> Hi Harm,
>     >>
>     >>>  I managed to drop about 300 lines, reducing
>     >>> it to a quarter of the original.
>     >>
>     >>
>     >> Unfortunately, I'm getting "Invalid UTF-8 string..." warnings
>     when I run
>     >> your revised file.  (I don't with the original...)
>     >>
>     >> -David
>     >
>     > Hi David,
>     >
>     > are you sure?
>     > I tested it with "2.15.39", "2.15.40" and "2.15.42" without any
>     problem.
>     I also had no problem, so I would assume that something went wrong
>     with
>     saving the attachment.
> Ah, OK...  Unfortunately, I've have no idea what is happening to the
> attachment, but I get the same errors whether I run the file with
> LilyPondTool,. Frescobaldi, or on the command line.  Possibly it has
> something to do with Windows XP; I don't know. The file works without
> a hitch within LilyDev.   

Then it is no problem with the attachment, and indeed, the error message
from LilyPond is

"non-UTF-8 input"

and not "Invalid UTF-8 string".  Likely a Pango error message.  So it is
probable that the regexp "." matches just single bytes in your case.
The interesting question is whether this is due to a different version
of the regex matching library, or due to a different locale.

Here is how the character set in my system declares itself:

out/bin/lilypond scheme-sandbox
GNU LilyPond 2.15.42
guile> (setlocale LC_CTYPE)

David Kastrup

reply via email to

[Prev in Thread] Current Thread [Next in Thread]