[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Strange regtest-comparison

From: Phil Holmes
Subject: Re: Strange regtest-comparison
Date: Sun, 15 Jul 2012 22:31:29 +0100

----- Original Message ----- From: "Thomas Morley" <address@hidden>
To: "Phil Holmes" <address@hidden>
Cc: "lilypond-devel" <address@hidden>
Sent: Sunday, July 15, 2012 10:20 PM
Subject: Re: Strange regtest-comparison

2012/7/15 Thomas Morley <address@hidden>:
2012/7/15 Phil Holmes <address@hidden>:
----- Original Message ----- From: "Thomas Morley"
To: "lilypond-devel" <address@hidden>
Sent: Sunday, July 15, 2012 3:05 PM
Subject: Strange regtest-comparison


I tried to follow CG 10.9.8 Verify regression tests, pasting my code
step by step into the relevant files, running make, make test-redo,
make check and fixing the occuring errors step by step.
Currently the regtest comparison returned some strange results (at
least for me).
Attached is a detail of it.

What does it means?


It's supposed to track something like memory usage.  These changes are
almost always ignored.

Phil Holmes

Just found this thread, starting here:

Regarding Graham's reply
and your advise above, I'll continue ignoring the .profile-file-changes.

Thanks again,

After several flops I _again_ set up a new build-directory, ran
successfully make test-baseline and make check.
Because my patch will break
`' from
Documentation/snippets I tried to paste an updated version into
Documentation/snippets/new, without success.
Lastly I pasted the following file (version and header changed, code unchanged!)

\version "2.15.42"

\header {
 lsrtags = "specific-notation, tweaks-and-overrides, staff-notation"

 texidoc = "
Another way to put the time signature in parenthesis

 doctitle = "Time signature in parentheses - method 3"

\relative c'' {
 \override Staff.TimeSignature #'stencil = #(lambda (grob)
(parenthesize-stencil (ly:time-signature::print grob) 0.1 0.4 0.4 0.1 ))
 \time 2/4
 a4 b8 c

_No_ other change in the _whole_ build-directory.

Running make test-redo resulted in the log-message:
"Please check the logfile collated-files.texilog.log for errors"

collated-files.texilog.log says:
*** Can't find test-output-distance.texidoc, skipping (l. 38313)
Max error number exceeded

Well, now I don't know how to proceed, being confused and puzzled.
Perhaps I do some simple error. But I really, really have no clue
about any reason.


If a change you make would break a snippet, you have to add an updated version to snippets/new and then run to update it into the snippets directory. As a hack, you can change the file in snippets, but this change would not persist.

Again, at this point I don't know why make can't find a file, but I would counsel deleting build for an error of this type.

Phil Holmes

reply via email to

[Prev in Thread] Current Thread [Next in Thread]