[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help with building LilyPond

From: Thomas Morley
Subject: Re: Help with building LilyPond
Date: Sun, 14 May 2017 20:34:52 +0200

2017-05-14 18:21 GMT+02:00 Winston, Charles R. <address@hidden>:

> Hi LilyPond Developers!
> First off, let me introduce myself. My name is Charles Winston, and I’m
> participating in the Google Summer of Code this year, working on improving
> the internal representation of chords, with mentor Carl Sorenson. I’ve just
> finished finals and so now I am really excited to get much more familiar
> with LilyPond and its community in this period of community bonding.

Hi Charles,

welcome to the pond.

I'm interested in the chords-topic myself ...

> I am having some trouble setting things up, specifically with building
> LilyPond. I‘ve installed LilyDev and downloaded the source code using
> lily-git successfully (I’ve been following the instructions on the LilyPond
> Contributor’s Guide). However, when I try to prepare to build LilyPond
> using the commands:
> sh --noconfigure
> mkdir -p build/
> cd build/
> ../configure

This is the recommended method, all ok so far.

> I get the error:
> WARNING: Please consider installing optional programs or files:  URW++ OTF
> fonts (download OTF files from '
> p=urw-core35-fonts.git;a=commit;h=79bcdfb34fbce12b592cce389fa7a19da6b5b018'
> and put them under '~/.local/share/fonts' etc., or use --with-urwotf-dir)

guile-2.0 < 1.9.0 (installed: 2.0.13) extractpdfmark (Optionally using
> Ghostscript >= 9.20 together with Extract PDFmark can significantly reduce
> the disk space required for building the documentation and the final PDF
> files.)

> ERROR: Please install required programs:  guile-config < 1.9.0 (installed:
> 2.0.13) (guile-devel, guile-dev or libguile-dev package) libguile
> (libguile-dev, guile-devel or guile-dev package). GUILE-with-rational-bugfix
> See INSTALL.txt for more information on how to build LilyPond
> It seems like I’m missing some files? The proper version of guile-config
> and libguile. Where can I get these?
> Thanks for the help,
> Charles
Obviously, you've guile-2.0.13 installed.
LilyPond still uses guile-1.7, please downgrade to this version (or
Then you should have all files in an acceptable version.

The support for guile-2.x is experimental and building LilyPond with
guile-2.x is pretty pointless (unless you would want to work on the guile2

The others are warnings, which you may ignore.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]