[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: compiling lilypond in debian stretch with self-compiled guile-1.8

From: David Kastrup
Subject: Re: compiling lilypond in debian stretch with self-compiled guile-1.8
Date: Thu, 19 Oct 2017 18:55:40 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.50 (gnu/linux)

Federico Bruni <address@hidden> writes:

> Il giorno gio 19 ott 2017 alle 18:21, Federico Bruni
> <address@hidden> ha scritto:
>> [...]
>> Then I run make again. This time it takes a few minutes, but the
>> final error is still the same:
>> echo /home/pippo/lilypond-git/scripts/build/out/help2man
>> /home/pippo/lilypond-git/scripts/build/out/help2man
>> /home/pippo/lilypond-git/scripts/build/out/help2man out/lilypond >
>> out/lilypond.1
>> help2man: can't get `--help' info from out/lilypond
>> Try `--no-discard-stderr' if option outputs to stderr
>> /home/pippo/lilypond-git/stepmake/stepmake/help2man-rules.make:26:
>> recipe for target 'out/lilypond.1' failed
>> make[1]: *** [out/lilypond.1] Error 127
>> make[1]: Leaving directory '/home/pippo/lilypond-git/lily'
>> /home/pippo/lilypond-git/stepmake/stepmake/generic-targets.make:6:
>> recipe for target 'all' failed
>> make: *** [all] Error 2
> I'd like to know how to avoid above error...

I have my own Guile 1.8 libraries.  I use something like

GUILE_CONFIG=/usr/local/tmp/guile-1.8/bin/guile-config ./configure ...

I got the same problem.  However, this appears to be because avoiding
the check for guile-config in this manner appears to _also_ disable the
check (and any useful default) for Guile.  So I have to do

GUILE=/usr/bin/guile GUILE_CONFIG=... ./configure ...

to get this working smoothly.  /usr/bin/guile happens to be a Guile-2.0
provided by Ubuntu.  It's fine since it is used for the scripts which
run ok under Guile-2.0.

David Kastrup

reply via email to

[Prev in Thread] Current Thread [Next in Thread]