[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Error compiling Lilypond 2.19.81

From: Peter Engelbert
Subject: Re: Error compiling Lilypond 2.19.81
Date: Thu, 12 Apr 2018 01:12:57 +0000

Hi Karlin,

thank you -- this is very good reading.  It's making my head spin, which
means I'm learning something :)  I was able to install guile 1.8 via the
repository for Debian Jessie. as far as I know I'm not using guile 2.x for
anything anyway, so i don't mind having 1.8 installed instead.

Perhaps it is wacky to install from the repository from an earlier version
of Debian?  Is that unusual?  I'm fairly new to Linux though i have some
background in programming, and I don't fully understand package management.

Thanks again,

On Wed, Apr 11, 2018 at 2:03 PM Karlin High <address@hidden> wrote:

> On 4/11/2018 3:48 PM, Peter Engelbert wrote:
> > In the meantime, I also noticed that for some reason Lilypond 2.18.2 is
> not
> > in the Debian Stretch (9) repository for ARM, but it IS in the Debian
> > Jessie (8) repository. So I was able to install 2.18.2 for the raspberry
> pi
> > by adding the Jessie repository. Is it’s absence in the Stretch
> repository
> > an oversight, or is there some reason for it?
> LilyPond depends on Guile 1.8; more recent versions are incompatible so
> far. Newer Debian versions have removed Guile 1.8. Here are a few
> threads from the lilypond-devel list that may be of interest.
> LilyPond in Debian
> <>
> compiling lilypond in debian stretch with self-compiled guile-1.8
> <>
> --
> Karlin High
> Missouri, USA

reply via email to

[Prev in Thread] Current Thread [Next in Thread]