[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

GSoC 2020: make hangs when making fonts

From: Owen Lamb
Subject: GSoC 2020: make hangs when making fonts
Date: Mon, 29 Jun 2020 13:42:46 -0700

Hi all,

On Friday, make started hanging when making the first .pfb font file,
displaying no new information after:

Making mf/out/feta11.pfb < mf
Copyright (c) 2000-2014 by George Williams. See AUTHORS for Contributors.
 License GPLv3+: GNU GPL version 3 or later <>
 with many parts BSD <>. Please read
 Based on sources from 20170812-ML-D.
 Based on source from git with hash:

After ctrl-C'ing the attempt, the following is displayed:

^Cmf2pt1: You'll need to install FontForge if you want feta11.pfb
autohinted (not required, but strongly recommended)
/home/dev/lilypond-git/build/.././mf/GNUmakefile:36: recipe for target
'out/feta11.log' failed
make[1]: *** [out/feta11.log] Interrupt
recipe for target 'all' failed
make: *** [all] Interrupt

At first, I thought it was my latest changes that broke it, but the build
fails no matter what commit or branch I checkout. So far, I've tried
running make on:

   - my own dev/lamb/GSoC-2020,
   - a few commits in my work's history,
   - the point at which current master and my branch diverge (i.e. what
   master was at right before I started work), and
   - the current state of master.

All of them provide the same error message described above.

FontForge is installed and functional, so I'm not sure why mf2pt1 thinks I
don't have it. I also tried installing a fresh copy of LilyDev in case I
somehow messed something up, but that didn't help either. Re-running
../configure from the build folder does not reveal any missing
dependencies. I'm at a loss as to what else to do!

Any ideas on what might have gone wrong?

Thanks in advance,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]