[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Almost built but not quite. Suggestions?

From: Mats Bengtsson
Subject: Re: Almost built but not quite. Suggestions?
Date: Sun, 16 Dec 2001 23:34:17 +0100

> > This is related to the lines on MetaPost found in INSTALL.txt.
> >
> I edited config.make so the following lines read:
>      INIMETAFONT = /usr/local/teTeX/bin/sparc-sun-solaris2.8/inimfont
>      INIMETAPOST = /usr/local/teTeX/bin/sparc-sun-solaris2.8/inimpost
> Now I get
>      make[2]: Leaving directory 
> `/usr/local/src/various/lilypond-stuff/lilypond-1.5.25/lily/include'
>      make[1]: Leaving directory 
> `/usr/local/src/various/lilypond-stuff/lilypond-1.5.25/lily'
>      make[1]: Entering directory 
> `/usr/local/src/various/lilypond-stuff/lilypond-1.5.25/mf'
>      /usr/local/teTeX/bin/sparc-sun-solaris2.8/inimpost  
> -interaction=nonstopmode  dump
>      This is MetaPost, Version 0.641 (Web2C 7.3.1) (INIMP)
>      ! I can't find file `dump'.
>      <*> dump

The problem is probably that configure didn't find the MetaPost
related parts. Try ones more to remove configure.cache, ensure
that inimpost and all the other TeX related binaries are in the
path and rerun configure. 
If it still doesn't work, make sure that the variable MFPLAIN_MP
in config.make is set to the full path of the file
(which can be found using the command 'kpsewhich').

I must say you have been very unfortunate with installation 
troubles, haven't heard about anything like these troubles
with Lilypond installations for several years. I got the
impression some other people have tried Solaris too, but 
you may have been unlucky with new versions of some software, 
the bison troubles were reported by some more people last week.
Keep up the struggle, you should be almost through now!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]