[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Installation Redhat 8, dependencies

From: Mats Bengtsson
Subject: Re: Installation Redhat 8, dependencies
Date: Thu, 17 Feb 2005 10:48:54 +0100
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041217

If you installed guile from source, than you should already have both
the runtime parts as well as the include files and lib files needed
when you compile LilyPond. If, instead, you had installed from RPMs,
you would have needed both a package called guile and another one
called guile-dev in order to install the same thing (in other words,
the split into guile and guile-dev is made by the RedHat packagers,
they both come from the same source code).

If you have installed Guile correctly, you should be able to run a
program called guile-config, for example
guile-config info
So, if you installed Guile in /usr/local/, you have to make sure that
/usr/local/bin/ is in the $PATH.

In older versions of LilyPond, the configure program saved information
in a file called config.cache, so it didn't notice if you had made any
changes to the system unless you removed this file. However, I think
this should no longer be a problem.


Peter Adamson wrote:
Perhaps someone could give me some pointers. I have not successfully installed LilyPond as of yet. I tried with the command-line:
        rpm -i lilypond-2.4.1-1.rh90.ccrma

Althought the package name contains "rh90", it is the one recommended for RH8 on the LilyPond website.

This is the chain of dependency errors I get as I try to install the successive packages that are required:

        guile >= 1.6.4-8 is needed by lilypond-2.4.1-1.rh90.ccrma is needed by guile-1.6.4-8
        glibc-common = 2.3.2-98 is needed by glibc-2.3.2-98
        glibc < 2.3.2 conflicts with glibc-common-2.3.2-101

I can't uninstall glibc because it is required by too many packages. I can't upgrade glibc because I don't have the right version of glibc-common and I can't upgrade glibc-common because I don't have the right version of glibc.

So I tried to install from source.
First I installed guile from source (guile-1.6.7.tar.gz).
Then I installed flex from source (flex-2.5.4a.tar.gz).
Then I unpacked lilypond-2.4.4.tar.gz
When I ./configure from ./lilypond-2.4.4 I get the following error:

        ERROR: Please install required programs:  echo no guile-config >= 1.6
        (installed: ) libguile (libguile-dev, guile-devel or guile-dev package).

I then tried to find libguile-dev. The LilyPond website installation instructions say this might be needed but does not supply a link. I searched for it but I have only found it in .deb package format. I don't know how to install a .deb package on RedHat.

Next I obtained and unpacked guile-devel. It directly installed files in usr/include/libguile/ so I assume that no make install is needed.

I tried ./configure from ./lilypond-2.4.4 again but got the same error:

        ERROR: Please install required programs:  echo no guile-config >= 1.6
        (installed: ) libguile (libguile-dev, guile-devel or guile-dev package).

Next I searched for guile-dev but could not find it. only seems to have guile. I found lots of discussions about guile-dev but no download. Am I missing something here?

I don't like to ask for help until I have exhausted all possible routes but I am definately out of my depth now.

Can anyone help?

Thanks a bunch,


lilypond-user mailing list

        Mats Bengtsson
        Signal Processing
        Signals, Sensors and Systems
        Royal Institute of Technology
        SE-100 44  STOCKHOLM
        Phone: (+46) 8 790 8463                         
        Fax:   (+46) 8 790 7260
        Email: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]