[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem with and Lilypond 2.19.82

From: Luca Danieli
Subject: Re: Problem with and Lilypond 2.19.82
Date: Fri, 14 Dec 2018 16:12:50 +0000

Hi Thomas,

your analysis has been very good.
I have almost solved the issue.
I just don't know what's the glyph name for the SEMI-SHARP and SEMI-FLAT

In the following code, I should add the ones for SEMI-SHARP and SEMI-FLAT.
Do you know what's the name of the glyph? I already tried (e.g. SEMI-SHARP) "accidentals.semi-sharp", "accidentals.semisharp" and "".
They didn't work, but it might be a problem of refreshing.


arrowGlyphs = #`(
        (,DOUBLE-SHARP . "accidentals.doublesharp")
        (,SHARP-RAISE  . "")
        (,SHARP        . "")
        (,SHARP-LOWER  . "")
        (,NATURAL-RAISE . "accidentals.natural.arrowup")
        (  0            . "accidentals.natural")
        (,NATURAL-LOWER . "accidentals.natural.arrowdown")
        (,FLAT-RAISE   . "accidentals.flat.arrowup")
        (,FLAT         . "accidentals.flat")
        (,FLAT-LOWER   . "accidentals.flat.arrowdown")
        (,DOUBLE-FLAT  . "accidentals.flatflat")

From: Thomas Morley <address@hidden>
Sent: 13 December 2018 23:20
To: Luca Danieli
Cc: David Kastrup; lilypond-user
Subject: Re: Problem with and Lilypond 2.19.82
Am Do., 13. Dez. 2018 um 23:11 Uhr schrieb Luca Danieli <address@hidden>:

> What it did was to replace the line #(ly:parser-set-note-names parser pitchnames)
> with #(ly:parser-set-note-names pitchnames)

convert-ly, correctly applied, would have done it for you ;)

> So I have got the same problem of before. Some accidentals are replaced with a X. Don't know how to solve it.

Well, first I made an experiment.
I included your code and tried to compile the most simple:

{ ceseh1 }

With 2.18.2 and 2.19.82 (converted)

In both version I get:
warning: Could not find glyph-name for alteration -3/4
2.18.2 is done with this warning
2.19.82 additionally prints some dummy accidental

> Am I the only one to have this problem?

Likely, but I have a hard time imagening your file ever worked:

Obviously you took
and changed it.
But while defining your pitchnames in 'arrowedPitchNames', you use
alterations like
(* FLAT 3/2)
(/ FLAT 2)
(/ SHARP 2)
(* SHARP 3/2)
There is no corresponding entry in 'arrowGlyphs' for those alterations, though.
Thus LilyPond-2.19.82 does not find any accidental-glyph to print,
warns you and (to make it more obvious) it prints the dummy instead.

Create additional entries in 'arrowGlyphs' for the alterations listed
above and it should work.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]