[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lwip-users] Lots of RAM

From: Frédéric BERNON
Subject: Re: [lwip-users] Lots of RAM
Date: Fri, 7 Sep 2007 14:22:39 +0200

I'm agree with Jonathan & Simon (but I think we should add $date$ and $revision$ CVS keyword, is there any objections to add them ?).

These references could perhaps help you :

http://lwip.scribblewiki.com/LwIP_Main_Page (main page of the wiki doc)
http://lwip.scribblewiki.com/images/lwip/c/c3/Lwip-doc.CVS_HEAD.pdf (lwIP doxygen file, it's not the last one, but it's often updated) http://opengroup.org/onlinepubs/007908799/index.html (most of system call, or functions like socket api - htonl() function by example) and of course, any good C reference (for itoa/atoi functions, but I don't get any reference here).

For sample you give us, there are all from C reference, or from "posix" system reference. So, of course, we can't change them.

About use of any prefix, to my point of view, use hungrian notation would be good, but, it's not the current coding style, and change it now would
be a long, long and dangerous operation, so, I think it will never be done.

But lot of lwIP functions are prefixed with their module name: mem_malloc() in in mem.h/.c, memp_malloc() in memp.h/.c, netif_add() in netif.h/.c, etc... Documentation is most of time just before their implementation in the ".c" file.

----- Original Message ----- From: "Goldschmidt Simon" <address@hidden>
To: "Mailing list for lwIP users" <address@hidden>
Sent: Friday, September 07, 2007 12:39 PM
Subject: RE: [lwip-users] Lots of RAM

I just think that the comments about a code change should be were the
code is changed.

I mus say I don't agree with that. We would end up with rather bloated
files where the actual code is hard to find!

About function names:
    itoa  should be named F_int_to_asc.
    atoi  should be named F_asc_to_int.
    htonl should be named F_host_to_networkorder.

These are all wellknown names and perhaps shouldn't change
but I include them as examples of how I would like it to be.
I also think it is a value in being able to directly
distinguish a function name from a variable name by
preceeding every function name with "F_".

I think a better way is to write a good manual to lwIP where all
functions and global variables are described so they are easy to find!
And as far as I know, we're on the way to having that in the wiki?


lwip-users mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]