[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [lwip-users] Renaming the defines?

From: address@hidden
Subject: Re: [lwip-users] Renaming the defines?
Date: Tue, 29 Nov 2011 21:53:00 +0100
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0) Gecko/20111105 Thunderbird/8.0

Matias Mandell wrote:
I would like to suggest that e.g. the error constant defines would be
prefixed with LWIP_
to make them more unique. Easier porting into existing platforms and
would perhaps avoid possible mix-ups?
I think that's a good idea. We already started to add the LWIP_ prefix to some defines, but I guess we didn't want to change all of them in fear of breaking too many existing ports. This is clearly not a thing to do for the 1.4.1 release, but it would be a nice-to-have for 1.5.0.

To prevent breaking existing ports or applications, a file that redefines the old style defines for backwards compatibility would be nice. As always wich such a time-consuming task, help (in the form of patches) is greatly appreciated.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]