[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [GMG-Devel] Python exception uploading video on CentOS 7

From: Ian Cross
Subject: Re: [GMG-Devel] Python exception uploading video on CentOS 7
Date: Mon, 9 Nov 2015 12:08:51 +0000

Hi ayleph,

Thanks for your reply, sorry for the delay in getting back to you I had to 
rebuild my VM to get a definitive answer. I have both gstreamer 0 and 1 
installed at versions 0.10.36 and 1.0.7-5 respectively. Sounds like it should 
be working for me then really...yum output below

Installed Packages
gstreamer.x86_64                                              0.10.36-7.el7     
gstreamer-plugins-base.x86_64                                 0.10.36-10.el7    
gstreamer-plugins-good.x86_64                                 0.10.31-11.el7    
gstreamer-python.x86_64                                       0.10.22-6.el7     
gstreamer-tools.x86_64                                        0.10.36-7.el7     
gstreamer1.x86_64                                             1.0.7-4.el7       
gstreamer1-plugins-base.x86_64                                1.0.7-5.el7       
gstreamer1-plugins-good.x86_64                                1.0.7-5.el7       


-----Original Message-----
From: ayleph [mailto:address@hidden] 
Sent: 31 October 2015 09:28
To: Ian Cross; address@hidden
Subject: Re: [GMG-Devel] Python exception uploading video on CentOS 7

On 10/25/2015 02:06 AM, Ian Cross wrote:
> Hi,
> I have a python exception when uploading video, the stack trace is below. I 
> installed the latest stable version (git clone 
> git:// -b stable) on the latest CentOS 7 
> today. Images and other functionality seem to work fine. I tried to upload 
> test WebM videos but neither of my samples worked:  
> and 
> The exception occurs on line 96 of media_types/video/ - 
> foreach() takes exactly 3 arguments (2 given).
> I am wondering if I have not installed gstreamer and python bindings 
> correctly or at expected versions? I installed packages gstreamer 
> gstreamer-python gstreamer-plugins-good. Any help much appreciated, thanks!

Hi Ian,

I'm not very familiar with CentOS. Do you know what version of gstreamer you're 
using? Latest MediaGoblin is designed to work with gstreamer-1.x.
I've personally had success with gstreamer-1.0, -1.4, and currently with -1.6.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]