[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Install bug?

From: Chuck Robey
Subject: Install bug?
Date: Mon, 4 May 1998 20:34:27 -0400 (EDT)

I am trying to get octave 2.0.12 set up for a FreeBSD package, and I
have to have a complete list of the installed files (so as to create a
packing list for the binary package, and handle de-installing).  Because
of this, I've been perusing the output of a 'make install', and have
found a section I find a little strange.  I'm not using octave-bug to
mail this in (I don't have the octave working yet), so I'm including the
octave-bug script from the new build, and also a listing of the install
part (I named that "iout").

Look near line 166 of that listing, you'll see a section that does
things with a bunch of *.cc files (search for balance.cc, it's the first
in the section of those I'm talking about).  You'll see *something* is
intended, but none of these files actually get installed at all.  I
think you did intend these guys get installed, so I thought I'd mention

I needed to make a couple of changes to get things working.  First, it
found, via uname, that I run FreeBSD(current, version 3.0), but
FreeBSD-3.0 is not among those numbers that you search for
automatically, so it rejects building shared libraries on a platform
that has always been using them.  I changed the configuration arguments
so that --host=i386-unknown-freebsd is added as a configuration flag,
but it would be better to change the configuration script so that it
seeks FreeBSD-* instead of a version number.

Second, FreeBSD shared libraries come in the form:


The minor _can_ be omitted, but not the major, and so I needed to modify
your configuration script to make so->so.2.0.  Further, you installed
your shared libraries into PREFIX/octave, which is not in the default
library directories that are initialized via ldconfig on system startup,
and doing the way you do is considered a security flaw.  An ordinary
user cannot overcome this problem, even with the use of LD_LIBRARY_PATH,
because the ldconfig program is restricted to root users, and then still
must follow LD_LIBRARY_PATH.  I changed your definition of the directory
to install libraries to PREFIX/lib.  This should be configurable via
flags to configure.

Chuck Robey                 | Interests include any kind of voice or data 
address@hidden         | communications topic, C programming, and Unix.
213 Lakeside Drive Apt T-1  |
Greenbelt, MD 20770         | I run Journey2 and picnic (FreeBSD-current)
(301) 220-2114              | and jaunt (NetBSD).

Attachment: octave-bug
Description: Binary data

Attachment: iout
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]