[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Octave Forge website / third sentence on the "Home" page

From: Philip Nienhuis
Subject: Re: Octave Forge website / third sentence on the "Home" page
Date: Mon, 11 Aug 2014 14:27:05 +0200
User-agent: Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0 SeaMonkey/2.26.1

<Michael Goffioul -windows pkg maintainer- cc'd>

Julien Bect wrote:
Le 09/08/2014 17:03, PhilipNienhuis a écrit :
Julien Bect wrote
> Hello all,
> Just a tiny suggestion concerning the Octave Forge website... I would
> remove the third sentence on the "Home" page :
> "In general the packages are designed to work with the latest
> development version of Octave, but it should be possible to use most
> packages with earlier versions."
> Indeed,
> 1) the first part is a little scary. It suggests (to me) that some
> packages might actually depend on features provided by unreleased
> versions of Octave... Is it really something that the Octave Forge
> maintainers would consider doing ? Not all users want to use
> versions.
The windows package cannot even be installed in Octave-4.1.0+ as
stuff has been removed (IIRC that is what the error messages suggest).
I need to install it in 3.9.0+ and then the installed windows package
OK in 4.1.0+ as well. So in a way what's currently on the OF site is
somewhat true, but....

According to its DESCRIPTION, the "windows" package should work for
Octave >= 3.2.0.

And it does.

If it doesn't work in Octave 3.6.4 or 3.8.1 (does it ?)

Yes it does.

then I would say that the package is broken... If it doesn't work in
Octave 3.8.2-RC2, 3.9.0+ or 4.1.0+, then it's not broken yet (but is
likely to become broken sooner or later :).

It cannot be installed, but isn't broken otherwise; to be compiled the binary modules need stuff deprecated in 3.7.+ and dropped in 4.1.x. However built binary modules (e.g., built in 3.9.0+) do work properly in 4.1.0+, as the binary interface (ABI?) apparently is still sufficiently compatible. (FYI: I use a mixed Octave-3.9.0+/4.1.0+ installations on Windows (see patch #8469).)

BTW this is also valid for other OF packages with binary module sources that need octave-map (I'm not sure if e.g. the control package has similar issues).

Another issue is that a windows package that is built in Octave 3.8.x doesn't work in 3.9.0+ and higher because the load command doesn't seem to properly recognize the binary modules. Same holds for control etc. Probably a moot point as few people would be able to mix them on Windows systems like one can on *nix systems. But anyway that is the main reason that I didn't include 3.8.x versions in the multi-version binary MXE installer of patch #8469); I'll post separately about that later on (I'm just back from holiday, cleaning up at home and attacking the back log at work has higher priorities this week).

It would be better to say that OF packages are supposed to work with the
latest *stable* version of Octave.

I essentially agree, although I don't think the word "stable" is used on
the Octave website. I suggest : "The packages are designed to work with
the latest release of Octave, but it is usually possible to use them
with earlier versions (see 'Dependencies' in the detailed description of
the package)."

I'd say "latest release" would be preferrable.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]