[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Minimum g++ version?

From: John W. Eaton
Subject: Re: Minimum g++ version?
Date: Mon, 24 Nov 2014 16:54:27 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Icedove/24.5.0

On 11/23/2014 09:28 PM, Rik wrote:

The configure.ac file is checking the g++ version twice which is
unnecessary.  In one case, it issues a warning if the version <= 3.0 and in
the other it issues a warning if version <= 3.5.  Which version should we keep?

Those tests were added a long time ago, originally to prevent people from going too far in attempts to compile Octave with GCC 1.x or other versions that clearly wouldn't work. Maybe now we could just remove the checks completely.

If you decide to leave them in, then I think it makes sense to just warn for versions earlier than 4.1.x.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]