[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: try/catch not swallowing errors

From: John W. Eaton
Subject: Re: try/catch not swallowing errors
Date: Sun, 14 Apr 2019 08:38:11 -0400
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.5.1

On 4/14/19 12:47 AM, Daniel Kraft wrote:
Hi Rik!

On 14.04.19 06:13, Rik wrote:
On 04/13/2019 09:00 AM, address@hidden wrote:
As far as I can tell, this is where the error is generated:


That looks correct to me.  When I do exactly the same (use error() in
C++) in an .oct file of mine, it works, though.  That's why I guess it
could be related to packages somehow.

It must be something else in either the parallel or the struct package.
I tried to install the parallel package, but it required struct, and I
was unable to install struct.

I ran into these issues as well, they are fixed in the repositories of
struct/parallel already (so I was able to install both packages from
their source repositories fine on 5.1).

Maybe I'm using the wrong repo or something, but I was unable to install the parallel package. I am using the sources found here


at HG ID

  97770ea46e93 tip

I executed make dist in the top-level directory to generate target/parallel-3.1.3.tar.gz. Attempting to install that with Octave 5.1.0, I see the errors in the attached log file.

Can you post exactly how you are building these package?

I can't be sure until I can try to run some tests, but looking at the sources for the parallel package, I suspect the problem is due to code that is attempting to cope with various changes in Octave internals related to error handling and that the code in the package is not doing the right thing now.


Attachment: typescript
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]