[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] installing paparizzi

From: Alston Pike
Subject: Re: [Paparazzi-devel] installing paparizzi
Date: Fri, 10 Apr 2009 08:48:33 -0500

You'll have to change the link in the applications so that it reads something like /home/<user name>/paparazzi3/paparazzi, depending on where you downloaded the source code.

Alston Pike
BSME 2009
The University of Alabama
(706) 594-2812

On Thu, Apr 9, 2009 at 6:27 PM, Michael Caughey <address@hidden> wrote:
I fixed part of my own problem by re-reading the Installation page yet again:

I had forgot to run:
sudo apt-get install paparazzi-dev

So now it does build and I can run it from the command line.

However the icon in the applications > other still doesnt work.

----- Original Message ----- From: "Michael Caughey" <address@hidden> Sent: Thursday, April 09, 2009 7:13 PM

Subject: Re: [Paparazzi-devel] installing paparizzi

Ok I was able to get that additional component Istalled and then to get paparazzi-bin installed.

I have modified my .bashrc to include the PAPARAZZI_HOME

I have also rebooted my computers.  The cion under application tells me that I need to set the PAPARAZZI_HOME.

When I run from the commandline I get the following error:
Unix.Unix_error (Unix.ENOENT, 'execve', '/sw/supervision/paparazzicenter").

I have run apt-get update and apt-get-upgrade on my Ubuntu 8.0.x box.

I have also grab the source code from svn and tried to build that:
I did a make clean then a make

It process the ml files then I get an error in files lpcusb.h and lpcusb.c, it lists a doven or more lines all having the same problem

lpcusb.h:39: error: expected ')' before '*' token.

I ran svn update first.

I suspect rather than actually being a problem with the code compilation, iti smore likely a configuration issue on my side.

any help?

----- Original Message ----- From: "Pascal Brisset" <address@hidden>
To: <address@hidden>
Sent: Wednesday, April 08, 2009 4:01 AM
Subject: Re: [Paparazzi-devel] installing paparizzi


it seems a dependency is missing in this package. Before I fix it, you can manually install the missing package:

sudo apt-get install libocamlnet-ocaml-dev


sudo apt-get install paparazzi-bin



Michael Caughey wrote:
I've downloaded the source for paparizzi, and I intend to build it eventually.  However prior to that I wanted to install the bin to take a look at it and insure I had all the dependancies.  I have Ubuntu 8.0.x. I ran the followin command:
 sudo apt-get install paparazzi-bin
 It looks like all the dependancies installed ok but now I'm getting the following error:
 Setting up speech-dispatcher (0.6.6-0ubuntu8) ...
Not starting speech-dispatcher, as /etc/default/speech-dispatcher does not
have RUN_SPEECHD=yes.
 Setting up paparazzi-bin (3.10.1) ...
/var/lib/dpkg/info/paparazzi-bin.postinst: line 10: ocamlfind: command not found
dpkg: error processing paparazzi-bin (--configure):
 subprocess post-installation script returned error exit status 127
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
 I check my disk to make sure I have not run out of spac and I have 75% free on a 160 Gig hard drive.
 Am I missing the ocamlfind dependancy?  I"m not even sure what that is to be honest with you.

Paparazzi-devel mailing list

Paparazzi-devel mailing list

Paparazzi-devel mailing list

Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]