[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-block] [PATCH] Replacing (and removing) get_ticks_per_sec() fu

From: Christian Borntraeger
Subject: Re: [Qemu-block] [PATCH] Replacing (and removing) get_ticks_per_sec() function with NANOSECONDS_PER_SECOND Signed-off-by: Rutuja Shah <address@hidden>
Date: Fri, 11 Mar 2016 13:12:25 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.6.0

On 03/11/2016 01:07 PM, Paolo Bonzini wrote:
> On 11/03/2016 12:44, Christian Borntraeger wrote:
>>> -    s->tick_offset_vmstate = s->tick_offset + delta / get_ticks_per_sec();
>>>> +    s->tick_offset_vmstate = s->tick_offset + delta / 
>> [...]
>> While technically correct, I do not like these changes. The interfaces 
>> expect "ticks",
>> and the fact that this happens to be a nanosecond does not help regarding 
>> readability.
> Actually, I think usage of "tick" in this file is just for historical
> reasons.

So in essence the patch is ok and we should try to get rid of the "tick" word 
in future


reply via email to

[Prev in Thread] Current Thread [Next in Thread]