[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Qemu-devel] How to use disk image from bochs?

From: qemuuser
Subject: [Qemu-devel] How to use disk image from bochs?
Date: Wed, 4 Feb 2004 10:52:35 -0500

I have a bochs disk image file with win98 [and several other applications]
sucesfully installed. I have been unable to manage to get qemu to boot to
this image file. The image file contains a single fat partition, which can be
mounted under linux with 
losetup -o 32256 /dev/loop1 windisk.img ; mount /dev/loop1 /mnt/winimg

However, I find myself unable to get qemu to boot to this image. It always
returns the bios error: 
"Disk I/O error"
"Replace the disk, and then press any key"

If a key is pressed, then the program terminates with the error:
"BIOS panic at rombios.c, line 1558" on the terminal.

I also tried copying the image with 'dd bs=512 skip=63', but it didn't
help. I also tried using the -hdachs option with 2031,16,63 [the geometry
bochs reports for the disk], but that didn't help either... although in
that case, if you pressed a key after the bios boot error, the message would
just repeat instead of qemu terminating with the bios panic message. 

Thanks in advance for any assistance, and for your attention. 

reply via email to

[Prev in Thread] Current Thread [Next in Thread]