[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] Alsa-lib not recognized?

From: Grzegorz Kulewski
Subject: Re: [Qemu-devel] Alsa-lib not recognized?
Date: Sun, 29 Aug 2004 00:37:23 +0200 (CEST)

On Sat, 28 Aug 2004, Marcello 'R.D.O.' Magnifico wrote:

Hi all,
got this while attempting to compile current CVS snapshot on a Slackware 9.1.

ld: cannot find -lasound

I appear having Alsa-lib installed and working. Have tried an upgrade via a 3rd party package from Linuxpackages.net, with no behavior change. Tried both alsa-lib 0.9.8 (stock from Slackware itself) and 1.0.2. Should I change something within
in order to have the library binary recognized? Strangely enough, nothing happens at object compile time, as include files seem to be recognized properly. Obviously, I have checked both my alsa-lib packages, and they naturally have their usual /usr/lib/libasound.so.version binary and symbolic links in their proper place. No surprise if this was the same problem of the guy who seems having no math library only at link time. Is GCC 3.2.3 SO buggy or what? Anyone has a clue to get out of this impasse?

If you are compiling qemu-fast (too) you need static version of alse-lib (too). Most Linux distributions lack libasound.a. If this is the case you can compile it manually (its easy - see INSTALL file in alsa-lib source tarball). Or change distribution (for example to Gentoo).

But as far as I know even with static alsa-lib you will still not be able to compile qemu-fast with recent binutils / gcc / glibc because of some nasty assertion failed error in ld during final linking. I reported it to this list and to Gentoo bugzilla but nobody done anything for about half a year and I am not binutils hacker or ld scripts expert yet...

So maybe you shoud try to compile without qemu-fast?

Hope this helps,

Grzegorz Kulewski

reply via email to

[Prev in Thread] Current Thread [Next in Thread]