[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] What happened to linuxppc-img from Freeoszoo

From: Jim C. Brown
Subject: Re: [Qemu-devel] What happened to linuxppc-img from Freeoszoo
Date: Mon, 27 Jun 2005 10:46:08 -0400
User-agent: Mutt/1.4i

> >    I tried to boot linuxppc image from freeoszoo with QemuCVS. kernel
> > boots ok but then I get errors that it cant read filesystem from dev hda.
> >    Also tried with 0.7.0 and it freezes at: Freeing unused kernel memory
> Late last year, QEMU reworked the disk geometry, and that can confuse old
> disk images.  The images expect an old style and the newer qemu offers a
> different geometry.

No, the geometry reported by 0.7.0 (which sees the disk properly and can mount
partition) and CVS (which can't see the partition table) are the same.

For the record, images I've used since qemu 0.5.2 still work fine with CVS.
(I only use raw images though.)

> qemu now more closely does what a real system does.  But I think somebody in
> the qemu user forum came across a situation where it wasn't true.  Don't
> remember the details, but I think it was for 512m sizes.  I don't remember
> well, so I could be wrong.  Anyway, it works better now than it did before.

Actually, the reason that linux-ppc.img broke was due to a hack for darwin/ppc.

I have yet to determine why (i'm not that familiar with PPC or IDE) but the
folllowing patch will fix it. I'm not sure why this small change caused things
to break in the first place.

--- ide.c.old   Sun Jun 26 23:13:40 2005
+++ ide.c       Sun Jun 26 23:13:25 2005
@@ -1491,7 +1491,7 @@
         /* XXX: currently a workaround for Darwin/PPC. Need to check
            the IDE spec to see if it is correct */
-        ide_set_signature(s);
+        //ide_set_signature(s);

Infinite complexity begets infinite beauty.
Infinite precision begets infinite perfection.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]