[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] [PATCH 3/3] block: allow BLOCK_IMAGE_CORRUPTED to have

From: Alberto Garcia
Subject: Re: [Qemu-devel] [PATCH 3/3] block: allow BLOCK_IMAGE_CORRUPTED to have a node name
Date: Thu, 19 Mar 2015 22:42:01 +0100
User-agent: Mutt/1.5.20 (2009-06-14)

(I forgot to Cc Eric in this series, doing it now)

On Thu, Mar 19, 2015 at 03:42:35PM -0400, Max Reitz wrote:
> >  # Emitted when a corruption has been detected in a disk image
> >  #
> >-# @device: device name
> >+# @device: device name, or node name if not present
> Normally, if a field in QMP is designed @device, it contains a
> device name. We do have combined device/node name fields, though (as
> of John's incremental backup series, at least), but those are named
> @node (which I proposed for patch 2, too).
> But renaming the field here will lead to breaking backwards
> compatibility. I think just adding a @node-name field and keeping
> @device as it is should be good enough here.

I was doing the same that we discussed for BlockJobInfo here, where
option b) seemed to have a bit more support:


But yeah I personally don't mind extending the event with a new field.
Would we make 'device' optional in this case?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]