[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] run qemu on x64 system ( ARCH=i386 or ARCH=x86-64) and

From: Marwa Hamza
Subject: Re: [Qemu-devel] run qemu on x64 system ( ARCH=i386 or ARCH=x86-64) and on x86 system
Date: Sun, 3 Apr 2016 20:30:59 +0200

but i tried the same thing with arm arch ( file system made by busybox) and i used sh shell and it worked well 

2016-04-03 20:20 GMT+02:00 Pranith Kumar <address@hidden>:
On Sun, Apr 3, 2016 at 9:50 AM, Marwa Hamza <address@hidden> wrote:
> hello , i tried to run qemu on x64 system ,
> those are steps that i followed
> i compile the kernel 4.4.1 with arch =i386
> i download busybox 1.21.0
> make ARCH=i386 menuconfig
> I checked the option to compile Busybox as a static executable
> make ARCH=i386 install
> cd _install
> mkdir proc sys dev lib etc etc/init.d
> gedit etc/inittab
> ::sysinit:/etc/init.d/rcS
> sudo chmod +x etc/inittab
> sudo gedit etc/init.d/rcS
> #!/bin/sh

Can you try changing this line to: "#!/sbin/ash"?

I am not sure busybox has sh shell installed or configured properly.
That is what your error message is pointing to atleast.

> starting init :/bin/sh exists but couldn’t execute it
> kernel panic – not syncing no working init found


reply via email to

[Prev in Thread] Current Thread [Next in Thread]