[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] -rtc clock=vm with -icount 1, sleep=off introduces unex

From: Frédéric Konrad
Subject: Re: [Qemu-devel] -rtc clock=vm with -icount 1, sleep=off introduces unexpected delays in device interactions
Date: Fri, 3 Mar 2017 20:50:06 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.2

Hi Jim,

I think Alex and Paolo worked on an mttcg/icount issue.
Not sure if its related or not.


On 03/03/2017 08:38 PM, Nutaro, James J. wrote:
> My original problem seems to stem from something that changed in the way that 
> device emulation and instruction execution interact (I'm guessing). To 
> reproduce the issue, I started a linux image with
> qemu-system-i386 -rtc clock=vm -monitor none -icount 1,sleep=off jack.img
> After booting, I run
> ping localhost
> The first round trip time reports look reasonable, being in the millisecond 
> to sub-millisecond range. These occur while the emulator is running slower 
> than real time. 
> After a bit, the emulator speeds up (skipping over idle periods during I/O?) 
> and the round trip times jump to hundreds of milliseconds, which I had not 
> expected.
> If you want to try this experiment yourself, you can get the disk image that 
> I used from here:
> http://www.ornl.gov/~1qn/qemu-images/jack.img
> Jim

reply via email to

[Prev in Thread] Current Thread [Next in Thread]