[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] -rtc clock=vm with -icount 1, sleep=off introduces unex

From: Alex Bennée
Subject: Re: [Qemu-devel] -rtc clock=vm with -icount 1, sleep=off introduces unexpected delays in device interactions
Date: Mon, 06 Mar 2017 13:08:56 +0000
User-agent: mu4e 0.9.19; emacs 25.2.8

Frédéric Konrad <address@hidden> writes:

> Hi Jim,
> I think Alex and Paolo worked on an mttcg/icount issue.
> Not sure if its related or not.

If you are running a tree post-MTTCG merge you will need to add Paolo's

  Subject: [PATCH 0/6] tcg: fix icount super slowdown
  Date: Fri,  3 Mar 2017 14:11:08 +0100
  Message-Id: <address@hidden>

> Fred
> On 03/03/2017 08:38 PM, Nutaro, James J. wrote:
>> My original problem seems to stem from something that changed in the way 
>> that device emulation and instruction execution interact (I'm guessing). To 
>> reproduce the issue, I started a linux image with
>> qemu-system-i386 -rtc clock=vm -monitor none -icount 1,sleep=off jack.img
>> After booting, I run
>> ping localhost
>> The first round trip time reports look reasonable, being in the millisecond 
>> to sub-millisecond range. These occur while the emulator is running slower 
>> than real time.
>> After a bit, the emulator speeds up (skipping over idle periods during I/O?) 
>> and the round trip times jump to hundreds of milliseconds, which I had not 
>> expected.
>> If you want to try this experiment yourself, you can get the disk image that 
>> I used from here:
>> http://www.ornl.gov/~1qn/qemu-images/jack.img
>> Jim

Alex Bennée

reply via email to

[Prev in Thread] Current Thread [Next in Thread]