[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-devel] device_del fail

From: Fam Zheng
Subject: Re: [Qemu-devel] device_del fail
Date: Thu, 30 Nov 2017 10:32:26 +0800
User-agent: Mutt/1.9.1 (2017-09-22)

Let's keep address@hidden on the list so other people can chime in.

On Thu, 11/30 10:05, Lying wrote:
> At 2017-11-29 14:29:17, "Fam Zheng" <address@hidden> wrote:
> >On Wed, 11/29 13:43, Lying wrote:
> >> Hello everybody, I encounter a error on my vm guest
> >> I remove my device on my guest is failed, following is detail message.
> >> I didn't add my audio device before running my guest, So i add audio with 
> >> "device_add" after running
> >> Then i can use it, so i remove it with "device_del", but when i do it 
> >> again, i
> >> can't use my audio device and cannot remove it.
> >
> >
> >I haven't tried unplugging an audio device myself but in general PCI hot 
> >unplug
> >needs guest cooperation so some infomation about guest is also helpful.  
> >Which
> >guest OS is this?
> >
> >What are the exact commands that you used and what are the messages from
> >host/guest when you device_del?
> >
> >Fam
> hello, thanks for your reply, and i'm sorry that i not notice at yesterday .
> following is my information:
>     guest : window-7
>     host : Ubuntu-16.04
>     qemu : 2.11.0-rc0
>     libvirt : 3.9
>    seabios : 1.10.74 (from qemu)
> exact commands:
>     add:"device_add 
> driver=vfio-pci,host=02:00.0,x-vga=on,multifunction=yes,id=gpu1"
>     remove:"device_del gpu1"
> and not messages when i running device_del. But i can see it still exist 
> while running commands "info pci"

Probably the guest didn't respond to the hot-unplug event. In your original
question you said it is an audio device but your command suggests it is a GPU
device. I'm not sure Windows driver can handle this. Have you tried different
guests, such as Linux?

Cc Alex who may know more.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]