[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Qemu-devel] [PATCH 04/14] tests: acpi: make pointer to RSDP 64bit
From: |
Laszlo Ersek |
Subject: |
Re: [Qemu-devel] [PATCH 04/14] tests: acpi: make pointer to RSDP 64bit |
Date: |
Tue, 15 Jan 2019 21:09:03 +0100 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.9.1 |
On 01/15/19 16:40, Igor Mammedov wrote:
> In case of UEFI RSDP doesn't have to be located in lowmem,
I suggest inserting a comma (,) after "UEFI". Currently the message
reads like
in case of UEFI RSDP, doesn't have to... ENOPARSE
:) It should be
in case of UEFI, RSDP doesn't have to...
Thanks
Laszlo
> it could be placed at any address. Make sure that test won't
> break if it is placed above the first 4Gb of address space.
>
> PS:
> While at it cleanup some local variables as we don't really
> need them.
>
> Signed-off-by: Igor Mammedov <address@hidden>
> ---
> tests/bios-tables-test.c | 10 ++++------
> 1 file changed, 4 insertions(+), 6 deletions(-)
>
> diff --git a/tests/bios-tables-test.c b/tests/bios-tables-test.c
> index 99d7bf8..c28c5c7 100644
> --- a/tests/bios-tables-test.c
> +++ b/tests/bios-tables-test.c
> @@ -26,7 +26,7 @@
> typedef struct {
> const char *machine;
> const char *variant;
> - uint32_t rsdp_addr;
> + uint64_t rsdp_addr;
> uint8_t rsdp_table[36 /* ACPI 2.0+ RSDP size */];
> GArray *tables;
> uint32_t smbios_ep_addr;
> @@ -86,13 +86,11 @@ static void test_acpi_rsdp_address(test_data *data)
>
> static void test_acpi_rsdp_table(test_data *data)
> {
> - uint8_t *rsdp_table = data->rsdp_table, revision;
> - uint32_t addr = data->rsdp_addr;
> + uint8_t *rsdp_table = data->rsdp_table;
>
> - acpi_fetch_rsdp_table(data->qts, addr, rsdp_table);
> - revision = rsdp_table[15 /* Revision offset */];
> + acpi_fetch_rsdp_table(data->qts, data->rsdp_addr, rsdp_table);
>
> - switch (revision) {
> + switch (rsdp_table[15 /* Revision offset */]) {
> case 0: /* ACPI 1.0 RSDP */
> /* With rev 1, checksum is only for the first 20 bytes */
> g_assert(!acpi_calc_checksum(rsdp_table, 20));
>
- [Qemu-devel] [PATCH 00/14] tests: acpi: add UEFI (ARM) testing support, Igor Mammedov, 2019/01/15
- [Qemu-devel] [PATCH 01/14] tests: acpi: add uefi_find_rsdp_addr() helper, Igor Mammedov, 2019/01/15
- [Qemu-devel] [PATCH 02/14] tests: acpi: make RSDT test routine handle XSDT, Igor Mammedov, 2019/01/15
- [Qemu-devel] [PATCH 03/14] tests: acpi: rename acpi_parse_rsdp_table() into acpi_fetch_rsdp_table(), Igor Mammedov, 2019/01/15
- [Qemu-devel] [PATCH 05/14] tests: acpi: fetch X_DSDT if pointer to DSDT is 0, Igor Mammedov, 2019/01/15
- [Qemu-devel] [PATCH 04/14] tests: acpi: make pointer to RSDP 64bit, Igor Mammedov, 2019/01/15
- [Qemu-devel] [PATCH 06/14] tests: acpi: add reference blobs arm/virt board testcase, Igor Mammedov, 2019/01/15
- [Qemu-devel] [PATCH 07/14] tests: acpi: skip FACS table if board uses hw reduced ACPI profile, Igor Mammedov, 2019/01/15
- [Qemu-devel] [PATCH 08/14] tests: acpi: introduce an abilty start tests with UEFI firmware, Igor Mammedov, 2019/01/15
- [Qemu-devel] [PATCH 09/14] tests: acpi: move boot_sector_init() into x86 tests branch, Igor Mammedov, 2019/01/15
- [Qemu-devel] [PATCH 10/14] tests: acpi: ignore SMBIOS tests when UEFI firmware is used, Igor Mammedov, 2019/01/15