[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] pcie_root_port: Add disable_hotplug option

From: Laine Stump
Subject: Re: [PATCH] pcie_root_port: Add disable_hotplug option
Date: Tue, 18 Feb 2020 22:02:19 -0500
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.4.1

On 2/18/20 1:40 PM, Julia Suvorova wrote:
On Tue, Feb 18, 2020 at 6:18 PM Laine Stump <address@hidden> wrote:

On 2/18/20 11:17 AM, Julia Suvorova wrote:
Make hot-plug/hot-unplug on PCIe Root Ports optional to allow libvirt
to manage it and restrict unplug for the entire machine. This is going
to prevent user-initiated unplug in guests (Windows mostly).
      -device pcie-root-port,disable-hotplug=true,...

Double negatives (e.g. "disable-hotplug=false") tend to confuse simple
minds like mine. Would it be any more difficult to make the name of the
option positive instead (e.g. "enable-hotplug") with the default set to

disable-hotplug=false will not be used, because it's default. And it
follows previous naming (''disable-acs').

Yeah, I don't like the name of that one either (or of "disable-modern" or "disable-legacy") but I don't follow qemu-devel closely so I didn't see them when their patches went by. But now is my chance to complain :-)

I can live with it either way, but still think it's much better to not have "negative" option names. Feel free to ignore, and I'll just be happy that I didn't accept it silently.

Also, is there a rhyme/reason for some options having true/false, and some being off/on? disable-acs seems to be true/false, but disable-modern is on/off. Doesn't make any difference to me in the end, but just thought I'd bring it up in case there might be a reason to use on/off instead of true/false for this one.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]