[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v5 07/16] hw/i386: Rename apicid_from_topo_ids to x86_apicid_from
From: |
Babu Moger |
Subject: |
[PATCH v5 07/16] hw/i386: Rename apicid_from_topo_ids to x86_apicid_from_topo_ids |
Date: |
Tue, 03 Mar 2020 13:57:36 -0600 |
User-agent: |
StGit/unknown-version |
For consistancy rename apicid_from_topo_ids to x86_apicid_from_topo_ids.
No functional change.
Signed-off-by: Babu Moger <address@hidden>
Reviewed-by: Igor Mammedov <address@hidden>
---
hw/i386/pc.c | 2 +-
include/hw/i386/topology.h | 6 +++---
2 files changed, 4 insertions(+), 4 deletions(-)
diff --git a/hw/i386/pc.c b/hw/i386/pc.c
index 3d13cd46d6..17cce3f074 100644
--- a/hw/i386/pc.c
+++ b/hw/i386/pc.c
@@ -1581,7 +1581,7 @@ static void pc_cpu_pre_plug(HotplugHandler *hotplug_dev,
topo_ids.die_id = cpu->die_id;
topo_ids.core_id = cpu->core_id;
topo_ids.smt_id = cpu->thread_id;
- cpu->apic_id = apicid_from_topo_ids(&topo_info, &topo_ids);
+ cpu->apic_id = x86_apicid_from_topo_ids(&topo_info, &topo_ids);
}
cpu_slot = pc_find_cpu_slot(MACHINE(pcms), cpu->apic_id, &idx);
diff --git a/include/hw/i386/topology.h b/include/hw/i386/topology.h
index 04f01e2a09..b9593b9905 100644
--- a/include/hw/i386/topology.h
+++ b/include/hw/i386/topology.h
@@ -112,8 +112,8 @@ static inline unsigned apicid_pkg_offset(X86CPUTopoInfo
*topo_info)
*
* The caller must make sure core_id < nr_cores and smt_id < nr_threads.
*/
-static inline apic_id_t apicid_from_topo_ids(X86CPUTopoInfo *topo_info,
- const X86CPUTopoIDs *topo_ids)
+static inline apic_id_t x86_apicid_from_topo_ids(X86CPUTopoInfo *topo_info,
+ const X86CPUTopoIDs *topo_ids)
{
return (topo_ids->pkg_id << apicid_pkg_offset(topo_info)) |
(topo_ids->die_id << apicid_die_offset(topo_info)) |
@@ -165,7 +165,7 @@ static inline apic_id_t
x86_apicid_from_cpu_idx(X86CPUTopoInfo *topo_info,
{
X86CPUTopoIDs topo_ids;
x86_topo_ids_from_idx(topo_info, cpu_index, &topo_ids);
- return apicid_from_topo_ids(topo_info, &topo_ids);
+ return x86_apicid_from_topo_ids(topo_info, &topo_ids);
}
#endif /* HW_I386_TOPOLOGY_H */
- Re: [PATCH v5 05/16] hw/i386: Remove unnecessary initialization in x86_cpu_new, (continued)
- [PATCH v5 02/16] hw/i386: Introduce X86CPUTopoInfo to contain topology info, Babu Moger, 2020/03/03
- [PATCH v5 04/16] machine: Add SMP Sockets in CpuTopology, Babu Moger, 2020/03/03
- [PATCH v5 06/16] hw/i386: Update structures to save the number of nodes per package, Babu Moger, 2020/03/03
- [PATCH v5 08/16] hw/386: Add EPYC mode topology decoding functions, Babu Moger, 2020/03/03
- [PATCH v5 07/16] hw/i386: Rename apicid_from_topo_ids to x86_apicid_from_topo_ids,
Babu Moger <=
- [PATCH v5 11/16] target/i386: Load apicid model specific handlers from X86CPUDefinition, Babu Moger, 2020/03/03
- [PATCH v5 09/16] target/i386: Cleanup and use the EPYC mode topology functions, Babu Moger, 2020/03/03
- [PATCH v5 10/16] hw/i386: Introduce apicid functions inside X86MachineState, Babu Moger, 2020/03/03
- [PATCH v5 12/16] hw/i386: Use the apicid handlers from X86MachineState, Babu Moger, 2020/03/03