[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

qemu broke booting of old RedHat floppies

From: Michael Tokarev
Subject: qemu broke booting of old RedHat floppies
Date: Wed, 20 Jan 2021 18:11:41 +0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.6.0

As someone noticed on IRC, old (2.x) RedHat floppies does not boot
in current qemu.  When qemu is booted from floppy image at
(download the "ISO image" link there, it really is an 1.44 floppy),
seabios says Boot failed and that's it.

I run git bisect with it, knowing that qemu 2.1 works fine, and
it pointed out to this commit which is oldish qemu-2.5+:

commit 4812fa27fa75bce89738a82a191755853dd88408
Author: John Snow <jsnow@redhat.com>
Date:   Fri Jan 22 15:51:05 2016 -0500

    fdc: change auto fallback drive for ISA FDC to 288

    The 2.88 drive is more suitable as a default because
    it can still read 1.44 images correctly, but the reverse
    is not true.

    Since there exist virtio-win drivers that are shipped on
    2.88 floppy images, this patch will allow VMs booted without
    a floppy disk inserted to later insert a 2.88MB floppy and
    have that work.

    This patch has been tested with msdos, freedos, fedora,
    windows 8 and windows 10 without issue: if problems do
    arise for certain guests being unable to cope with 2.88MB
    drives as the default, they are in the minority and can use
    type=144 as needed (or insert a proper boot medium and omit
    type=144/288 or use type=auto) to obtain different drive types.

    As icing, the default will remain auto/144 for any pre-2.6
    machine types, hopefully minimizing the impact of this change
    in legacy hw to basically zero.

    Reviewed-by: Eric Blake <eblake@redhat.com>
    Signed-off-by: John Snow <jsnow@redhat.com>
    Message-id: 1453495865-9649-13-git-send-email-jsnow@redhat.com

Now, I don't even know where to put that "type=144/288/auto" thing,
I tried this:


but it says that format=raw does not support "type=144" option.

And it's even more: I don't remember which size should be an 1.44Mb floppy :))
The file size of that image is 1492992 bytes which does not look like it is of
standard size, but I can't find which size it should be.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]