[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Savannah-hackers-public] bzr access problems

From: Tim Cross
Subject: Re: [Savannah-hackers-public] bzr access problems
Date: Mon, 17 Oct 2011 11:25:42 +1100

On Fri, Oct 14, 2011 at 11:39 AM, Martin Pool <address@hidden> wrote:
> On 14 October 2011 06:48, Michael J. Flickinger <address@hidden> wrote:
>> James Cloos wrote:
>>>>>>>> "MP" == Martin Pool <address@hidden> writes:
>>> MP> Was bzr upgraded, or the server...?
>>> Someone recently posted that sv had been updated to bzr 2.4.
>>> -JimC
>> Bazaar is at (bzr) 2.3.1
>> Does bzr 2.4 fix any bugs which could have potentially caused this?
> There are a few different bugs or symptoms being discussed:
>  1- permission error on locks
>  2- connection drop while connecting
>  3- connection drop after exactly an hour
> I haven't heard of 1 or 3 happening anywhere else.  If they were in
> bzr itself I probably would have heard of them happening on Launchpad,
> and I haven't, so I suspect they are something in the Savannah
> environment.
> 2 I have heard elsewhere and it is typically an environmental or
> installation problem causing bzr to stop just after accepting the
> connection.
> So I'm not sure that upgrading to 2.4 will specifically fix them, but
> it will improve network speed and memory usage, which will probably
> help you generally, and if these problems are load-related it may make
> them go away.  2.4.0 was a couple of months ago so it's been well
> tested by other people and going to 2.4.1 should be a safe upgrade.
> hth,
> Martin

Hi All,

Eli suggested I provide some additional info from my bzr.log after a
pull request with the Dhpss switch. I've included it below.

To ensure some clarity, a quick summary

- The failure happens very quickly i.e. within a minute or so of
issuing the command
- I have no problems accessing bzr repositories on other hosts, such
- I also got the same error when trying to access other bzr
repositories on savannah
- I can access the git repository on savannah with no problems
- I only see this error on my work system, which has a fast internet
- I have been accessing the bzr repository without problems before
last week for the last couple of years (since no long after the move
from CVS)
- I am running Xubuntu 11.10 (upgraded today). Was running 11.04 last week.
- Did not see any problems until Monday last week. All worked fine the
previous week.
- When attempting to access the repository via http, the error message
reports permission problems with locking files. I do not see this
error with the native bzr:// method.
- I have no problems accessing the repository from my home machine
(different, but slower network connection).

The error message I got this morning is

address@hidden:~/bzr/emacs/trunk$ bzr -Dhpss pull
bzr: ERROR: Connection closed: Unexpected end of message. Please check
connectivity and permissions, and report a bug if problems persist.
HPSS calls: 10 (1 vfs) <
object at 0xa8af30c>

and the bzr log entry is

Mon 2011-10-17 10:57:41 +1100
0.036  bazaar version: 2.4.1
0.036  bzr arguments: [u'-Dhpss', u'pull',
0.059  looking for plugins in /home/tcross/.bazaar/plugins
0.059  looking for plugins in /usr/lib/python2.7/dist-packages/bzrlib/plugins
0.081  encoding stdout as sys.stdout encoding 'UTF-8'
0.235  opening working tree '/home/tcross/bzr/emacs/trunk'
0.329  hpss: Built a new medium: SmartTCPClientMedium
0.329  hpss call:   'get', '/emacs/trunk'
0.329               (to bzr://
0.966     result:   ('ReadError', 'emacs/trunk')
0.981  hpss call:   'BzrDir.open_2.1', 'emacs/trunk/'
0.981               (to bzr://
1.245     result:   ('yes', 'no')
1.245  hpss call:   'BzrDir.open_branchV3', 'emacs/trunk/'
1.245               (to bzr://
1.573     result:   ('branch', 'Bazaar Branch Format 7 (needs bzr 1.6)\n')
1.573  hpss call:   'BzrDir.find_repositoryV3', 'emacs/trunk/'
1.573               (to bzr://
1.817     result:   ('ok', '..', 'yes', 'no', 'yes', 'Bazaar
repository format 2a (needs bzr 1.16 or later)\n')
1.818  hpss call:   'BzrDir.open_2.1', 'emacs/'
1.818               (to bzr://
2.059     result:   ('yes', 'no')
2.059  hpss call:   'BzrDir.find_repositoryV3', 'emacs/'
2.059               (to bzr://
2.303     result:   ('ok', '', 'yes', 'no', 'yes', 'Bazaar repository
format 2a (needs bzr 1.16 or later)\n')
2.303  hpss call:   'Repository.is_shared', 'emacs/'
2.303               (to bzr://
2.556     result:   ('yes',)
2.567  hpss call:   'Branch.get_stacked_on_url', 'emacs/trunk/'
2.567               (to bzr://
2.823     result:   ('NotStacked',)
2.866  hpss call:   'Branch.last_revision_info', 'emacs/trunk/'
2.866               (to bzr://
3.111     result:   ('ok', '106094',
3.112  hpss call:   'Branch.get_config_file', 'emacs/trunk/'
3.112               (to bzr://
3.358  decoder state: buf[:10]='',
3.359  Transferred: 2kB (0.7kB/s r:1kB w:1kB)
3.397  Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line
946, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line
1150, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line
699, in run_argv_aliases
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 721, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 135,
in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 165,
in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1076, in run
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line
217, in write_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line
1017, in pull
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1109, in pull
    possible_transports=possible_transports, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line
217, in write_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 3376, in pull
    merge_tags_to_master=not source_is_master)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 3506, in _pull
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line
217, in write_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 3319,
in _update_revisions
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line
217, in write_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 3294, in fetch
    fetch_spec = fetch_spec_factory.make_fetch_spec()
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 399,
in make_fetch_spec
    must_fetch, if_present_fetch = self.source_branch.heads_to_fetch()
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 3067,
in heads_to_fetch
    return branch.Branch.heads_to_fetch(self)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1552,
in heads_to_fetch
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 392,
in get_user_option_as_bool
    s = self.get_user_option(option_name, expand=expand)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 370,
in get_user_option
    value = self._get_user_option(option_name)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1370,
in _get_user_option
    value = source()._get_user_option(option_name)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 835,
in _get_user_option
    value = self._get_parser().get_value(section, option_name)
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 1691,
in _get_parser
    return self._config._get_configobj()
  File "/usr/lib/python2.7/dist-packages/bzrlib/", line 3144,
in _get_configobj
    'Branch.get_config_file', path)
  File "/usr/lib/python2.7/dist-packages/bzrlib/smart/", line
145, in call_expecting_body
    method, args, expect_response_body=True)
  File "/usr/lib/python2.7/dist-packages/bzrlib/smart/", line
81, in _call_and_read_response
  File "/usr/lib/python2.7/dist-packages/bzrlib/smart/",
line 299, in read_response_tuple
  File "/usr/lib/python2.7/dist-packages/bzrlib/smart/",
line 264, in _wait_for_response_args
  File "/usr/lib/python2.7/dist-packages/bzrlib/smart/",
line 286, in _read_more
    "Unexpected end of message. "
ConnectionReset: Connection closed: Unexpected end of message. Please
check connectivity and permissions, and report a bug if problems

3.397  return code 3
[ 3058] 2011-10-17 10:57:44.522 INFO: HPSS calls: 10 (1 vfs)
< object at 0xa8af30c>

Tim Cross

reply via email to

[Prev in Thread] Current Thread [Next in Thread]