[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Savannah-hackers-public] FYI: git was not responding: fixed

From: Michael J. Flickinger
Subject: Re: [Savannah-hackers-public] FYI: git was not responding: fixed
Date: Fri, 02 Dec 2011 20:23:50 -0500
User-agent: Waffles

On 12/2/11 8:13 PM, Michael J. Flickinger wrote:
On 12/2/11 4:54 AM, Jim Meyering wrote:
About an hour ago, for more than 20 minutes,'s git server was dead.

A restart attempt failed:

$ service xinetd restart
Stopping internet superserver: xinetd.
Starting internet superserver: xinetd failed!

Logs gave no indication of why it failed.
A little later I tried a simple "start", and that worked. Go figure.

$ service xinetd start
Starting internet superserver: xinetd.

This has happened before when a bunch of stale git processes piled up.
Did you check how many git processes, via xinetd, were running?

Further explanation:

In "/etc/xinetd.d/git" we limit the amount of instances to 40--to avoid thousands of git processes straining the server.

From time to time, stale ones accrue... When we get to 40 of them, xinetd won't spawn new git processes.

Michael J. Flickinger

reply via email to

[Prev in Thread] Current Thread [Next in Thread]