[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Using command line '-X' to send commands to multiuser session

From: Steve Scrimpshire
Subject: Re: Using command line '-X' to send commands to multiuser session
Date: Thu, 13 Apr 2006 03:15:17 -0000

On Wed, 12 Apr 2006 18:58:37 -0700
Rod Nussbaumer <address@hidden> wrote:

> Screen Gnurus:


> Here is a simple example of what I mean...
> $ screen -v
> Screen version 4.00.02 (FAU) 5-Dec-03
> $ screen -S test01/ -list
> There is a suitable screen on:
>          21614.pts-88.edevel23pc (Multi, attached)
> 1 Socket in /tmp/screens/S-test01.
> $ screen -S test01/21614 -x
> [detached]
> $ screen -S test01/21614 -X 'stuff ls -al'
> Cannot opendir /tmp/screens/S-test01: Permission denied
> This sounds, on the surface, to be fairly easy to 'fix'. Any pointers? 
> Anyone already done this?
>     ---   rod.

Disclaimer: I am no guru

I ran into a similar problem when trying to create a menu item in fluxbox
executing screen through Eterm:

[exec] (Irssi) {Eterm -g 95x24+0+0 -x -0
--scrollbar=off --buttonbar 0 --trans --cmod 70 -c white -e screen -D -R}

I tried everything to fix it. Then I did 'man screen' and discovered this:

"... the user can specify any mode 700 directory in the environment variable 

So, I created a directory in my home directory for my sockets:
mode 700
and edited my ~/.bashrc to include:
export SCREENDIR=~/tmp

Steve Scrimpshire
   The average household contains 280 blank sheets of paper.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]