[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: using <left-arrow> in bind - SOLVED

From: Eric Smith
Subject: Re: using <left-arrow> in bind - SOLVED
Date: Sat, 13 Jun 2015 15:42:49 +0200
User-agent: Mutt/1.5.23 (2014-03-12)

luteijn wrote on Sat-13-Jun 15  8:34AM
> What you should be sending in your case is <ESC>[D (three bytes, <ESC> is
> the same character as ctrl-[, rendered as ^[. Control sequences can be
> entered in 'stuff' in the caret notation, so 'stuff ^[[D' should work. Note
> that you do need two open-square-brackets next to each other. Right arrow
> would be ^[[C, up and down use A and B, another useful key is home: 'stuff
> ^[[1~', maybe followed by a few right arrows, if you have a long command of
> variable length that you have a variable addition to near the start.

Yes <ESC> is an elegant replacement for the control char.
But this only works for me when the char character is in the
definition of the key being bound and not when the control
character is in the command itself. - On both mac and ubuntu

^B (literally) give a left-arrow.
here is my final binding:
bind ! eval colon 'stuff "!   zsh -c \"    \""' 'stuff ^B^B^B'
(three left arrows)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]