[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cursor problems with some applications in linux console

From: David Woodfall
Subject: Re: Cursor problems with some applications in linux console
Date: Tue, 16 Oct 2018 00:40:00 +0100
User-agent: Agent Provocateur

On Monday 15 October 2018 21:29,
Dave Woodfall <address@hidden> put forth the proposition:
> On Monday 15 October 2018 21:26,
> Jostein Berntsen <address@hidden> put forth the proposition:
> >
> > What do you get for output when running "echo $TERM" in the plain linux
> > console?
> >
> > Can you get input from this page?
> >
> >
> >
> > and this?
> >
> >
> >
> > Jostein
> Thanks for the links.
> TERM is set to 'linux', or 'screen.linux' in screen when I mostly use
> those apps.
> tput cnorm sets the cursor back to the default, so maybe cnorm is
> being set. According to infocmp for linux, cnorm is set to \E?25h.
> Screen has an extra \E[34h at the start. I'll experiment a bit and
> see what happens if I change it.

I'm not sure what I'm doing wrong, but setting termcapinfo seems to
have no effect. I tried to get all possible combinations with:

termcapinfo linux cnorm=\E[?34h\E[?3c
termcapinfo screen cnorm=\E[?34h\E[?3c
termcapinfo screen.linux cnorm=\E[?34h\E[?3c

But in screen infocmp | grep cnorm still shows:


Isn't it meant to show the changed setting? I tried running mutt and
finch, but they still reset the cursor.

The first line of infocmp:

#       Reconstructed via infocmp from file:
#       /usr/share/terminfo/s/screen.linux
screen.linux|screen in linux console,

TERM is screen.linux
Screen version 4.06.02


"I can't complain, but sometimes I still do."
    -- Joe Walsh

                                                            .--.  oo

reply via email to

[Prev in Thread] Current Thread [Next in Thread]