speechd-discuss
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH] add an initial module detection algorithm


From: Andrei Kholodnyi
Subject: [PATCH] add an initial module detection algorithm
Date: Tue, 30 Nov 2010 13:42:50 +0100

> Hi Andrei,
> A status value seems good to me. ?It could return a list, I suppose,
> but that would require more lines of code in the caller to deal with
> that list.
> I'd also be fine with renaming it, though I can't think of many suitable
> candidates. ?detect_and_request_modules, perhaps?

Hi Chris,

I think it would make code more readable, e.g. like

GList detected_modules = detect_output_modules(MODULEBINDIR);
g_list_foreach (detected_modules, wrapper_of_module_add_load_request, NULL);
module_load_requested_modules();

Then we do not need any name change for detect_output_modules,
since it will do exactly what is stated in it's name.

I'm not very keen on this change, so if you'll decide to do it, I'll
be happy to review your patch.
Otherwise I'm quite fine with your current implementation as well.

Andrei.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]