[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Texmacs-dev] Re: TeXmacs+Axiom

From: Ralf Hemmecke
Subject: [Texmacs-dev] Re: TeXmacs+Axiom
Date: Tue, 22 May 2007 13:56:24 +0200
User-agent: Thunderbird (X11/20070326)

On 05/22/2007 11:14 AM, Martin Rubey wrote:
Ralf Hemmecke <address@hidden> writes:

I tried to put it at /usr/lib/texmacs/TeXmacs/bin/tm_axiom .

Well, at least I don't see strange output. I can enter Axiom commands and I
see... *nothing*. No output at all, only the input that I type is all that I

When you start the gcc'd (modified) tm_axiom.c directly, does it start

I took your tm_axiom.c, compiled it and moved the result to
/usr/lib/texmacs/TeXmacs/bin/tm_axiom .

Hyperdoc pops up, but if I type 1+2 and press ENTER, I get no output on the console.

Try also to start it in a directory that does not contain an ".axiom.input".
woodpecker:~>cat axiom.input
)set output tex on
)set output algebra off
)set compiler args -Fasy -Fao -flsp -laxiom -DAxiom -Y
$AXIOM/../../share/algebra -v -O

does your version of axiom read axiom.input or .axiom.input at startup?  (Mine
reads .axiom.input)

I don't actually know whether Axiom reads the file with our without initial dot. I only know that it was changed from one to the other sometime. If have to look it up. But anyway, I tried both options and none gives console output, except

verbatim:channel:promptlatex:\red$\rightarrow$\ verbatim:1+2
channel:promptlatex:\red$\rightarrow$\ verbatim:4
channel:promptlatex:\red$\rightarrow$\ verbatim:


reply via email to

[Prev in Thread] Current Thread [Next in Thread]