[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Weird behaviour when entering the filename

From: Michael Albinus
Subject: Re: Weird behaviour when entering the filename
Date: Tue, 26 Jan 2010 13:50:00 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1.91 (gnu/linux)

Francis Moreau <address@hidden> writes:

> Ok busybox (1.4.2) supports LS_COLORS, but it should be set to "none"
> value. I tried this on my host and setting this env variable to "none"
> just make ls(1) complains. I don't know the details about the possible
> settings but it seems that their values depends on the ls(1) versions.
> BTW, what does 'co' value mean ?

Try "dircolors --print-database | more" to see default values of
$LS_COLORS, and their syntax. 'co' is an abbreviation for 'COLOR=none',
which worked for me. Recent versions of dircolor under Ubuntu 9.04
(dircolors 6.10) and RHEL 5.2 (dircolors 5.97) do not honor this; there
is the comment

# The keywords COLOR, OPTIONS, and EIGHTBIT (honored by the
# slackware version of dircolors) are recognized but ignored.

So you might check the following setting:

$ ls -al
$ export 
$ ls -al

> Thanks

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]