[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Weird behaviour when entering the filename

From: Francis Moreau
Subject: Re: Weird behaviour when entering the filename
Date: Tue, 26 Jan 2010 14:20:57 +0100

On Tue, Jan 26, 2010 at 1:50 PM, Michael Albinus <address@hidden> wrote:
> Francis Moreau <address@hidden> writes:
>> Ok busybox (1.4.2) supports LS_COLORS, but it should be set to "none"
>> value. I tried this on my host and setting this env variable to "none"
>> just make ls(1) complains. I don't know the details about the possible
>> settings but it seems that their values depends on the ls(1) versions.
>> BTW, what does 'co' value mean ?
> Try "dircolors --print-database | more" to see default values of
> $LS_COLORS, and their syntax. 'co' is an abbreviation for 'COLOR=none',
> which worked for me. Recent versions of dircolor under Ubuntu 9.04
> (dircolors 6.10) and RHEL 5.2 (dircolors 5.97) do not honor this; there
> is the comment
> # The keywords COLOR, OPTIONS, and EIGHTBIT (honored by the
> # slackware version of dircolors) are recognized but ignored.
> So you might check the following setting:
> $ ls -al
> $ export 
> LS_COLORS='no=00:fi=00:di=00:ln=00:pi=00:so=00:do=00:bd=00:cd=00:or=00:su=00:sg=00:tw=00:ow=00:st=00:ex=00:*=00'
> $ ls -al

This doesn't work for busybox.

Anyways, I think there're not much solutions for this: either
Tramp/Emacs is teached to unescape filename or make Tramp to append
'--color=never' when it's supported assuming that all ls(1)
implementations used 'never'.

Otherwise the LS_COLORS or --color should depend on the remote url.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]