[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: default remote shell in tramp

From: Vinh Nguyen
Subject: Re: default remote shell in tramp
Date: Mon, 19 Jul 2010 20:38:45 -0700

Sorry for the lag -- I was busy migrating systems.  See below.

On Mon, Jun 28, 2010 at 7:55 AM, Terrence Brannon <address@hidden> wrote:
> On Thu, Jun 17, 2010 at 3:27 PM, Michael Albinus <address@hidden>
> wrote:
>> Vinh Nguyen <address@hidden> writes:
>> > I tried this before and I just tried it again.  Issue is the commands
>> > I'm looking for is in PATH that is defined in my .bashrc file on the
>> > remote machines.  Hence, I think the error is coming from the fact
>> > that /bin/sh is used (as the error states).
>> >
>> > I think the solution is to have tramp use bash on my remote machine.
>> > Does this make sense?
>> Yes. You could change the used remote shell in `tramp-methods' to
>> bash. If you, for example, use "ssh", you could apply
>> (setcdr (assoc 'tramp-remote-sh (assoc "ssh" tramp-methods))
>> '("/bin/bash"))
> For some reason, that is not doing anything:
>  (require 'tramp)
> (setcdr (assoc 'tramp-remote-sh (assoc "ssh" tramp-methods)) '("/bin/bash"))
> (setcdr (assoc 'tramp-remote-sh (assoc "scp" tramp-methods)) '("/bin/bash"))
> (setcdr (assoc 'tramp-remote-sh (assoc "scp1" tramp-methods))
> '("/bin/bash"))
> (setcdr (assoc 'tramp-remote-sh (assoc "scp1_old" tramp-methods))
> '("/bin/bash"))
> (setcdr (assoc 'tramp-remote-sh (assoc "scp2" tramp-methods))
> '("/bin/bash"))
> (setcdr (assoc 'tramp-remote-sh (assoc "scp2_old" tramp-methods))
> '("/bin/bash"))
> But even with that, when I type
> M-x shell
> and then echo $0
> the response is /bin/sh not /bin/bash

Same as before -- emacs hang and I needed to do C-g C-g.  Following at
the end of debug.  I believe stuff after dollar might be from after
C-g C-g.

20:34:25.329031 tramp-maybe-open-connection (3) # Found remote shell
prompt on `SERVER'
20:34:25.329366 tramp-send-command (6) # exec env ENV=''
PROMPT_COMMAND='' PS1=\#\$\  PS2='' PS3='' /bin/bash
20:34:35.793861 tramp-accept-process-output (3) # Opening connection
for SERVER using ssh...done

reply via email to

[Prev in Thread] Current Thread [Next in Thread]