[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: TRAMP hanging on “Waiting for prompts …”

From: Sean Whitton
Subject: Re: TRAMP hanging on “Waiting for prompts …”
Date: Mon, 26 Sep 2011 12:05:31 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.3 (gnu/linux)

Dear Michael,

On 26 Sep 2011 at 10:21Z, Michael Albinus wrote:

>> Been happily using TRAMP for months but all of a sudden it’s hanging
>> on “Waiting for prompts from remote server”.  Have tried on a
>> different machine with identical Emacs config and it works fine, so
>> I think there might be a cache file that’s corrupted that I need to
>> remove, or something?  I’ve tried deleting ~/.emacs.d/tramp but that
>> doesn’t help.

> You must stop Emacs, delete ~/.emacs.d/tramp, and restart Emacs then.
> ~/.emacs.d/tramp is written when exiting Emacs.

> Much simpler is to call "M-x tramp-cleanup-all-connections", which has
> the same effect.

Yeah that’s what I did; thanks for pointing me at that M-x command.

>> 10:37:03.026874 tramp-send-command (6) # exec ssh -l swhitton -e
>> none athena

> ...

>> 10:37:04.032096 tramp-accept-process-output (10) # *tramp/ssh
>> address@hidden run 10:37:04.904014 tramp-accept-process-output (3)
>> # Opening connection for address@hidden using ssh...done
>> 10:37:04.904150 tramp-file-name-handler (1) # Interrupt received in
>> operation (expand-file-name /athena:htdocs/blog/entries/ nil)

> This is less than 2 seconds. Have you interrupted the connection
> immediately?

I’ve let it last much longer than this in the past, and there is no
change—I just hit C-g quickly this time because I was only running it to
generate the debug output to e-mail to the list :-)

> According to the traces, the remote server didn't return any string
> (yet). What happens, if you call in a shell

> # ssh -l swhitton -e none athena

It works fine; I get a prompt.


Attachment: pgpHG05M5AJXY.pgp
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]