[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[solved] Re: remoting ESS/R with tramp

From: Tom Roche
Subject: [solved] Re: remoting ESS/R with tramp
Date: Fri, 13 Jan 2012 12:43:13 -0500
User-agent: GNU Emacs (x86_64-pc-linux-gnu, GTK+ Version 2.20.1)

Tom Roche Fri, Jan 13, 2012 at 9:26 AM
>> I appended

>> (add-to-list 'tramp-remote-path 'tramp-own-remote-path)

>> to [the tramp stanza in my init.el], byte-compile-file init.el, and
>> restarted emacs. But restart abended with

>> *Backtrace*
>>> Debugger entered--Lisp error: (void-variable tramp-remote-path)
>>>   add-to-list(tramp-remote-path tramp-own-remote-path)

Michael Albinus Fri, 13 Jan 2012 15:36:58 +0100
> My bad. I will fix it in Tramp 2.2.4 (and in Emacs 24.1,

Meanwhile, your workaround works: my init.el tramp stanza is now

> ; ------------------------------------------------------------------
> ; tramp
> ; ------------------------------------------------------------------
> (require 'tramp) ; if not already
> (require 'tramp-sh) ; temporary workaround: see
> ;
> ;;; from 
> (tramp-set-completion-function "ssh"
>   '((tramp-parse-sconfig "/etc/ssh_config")
>     (tramp-parse-sconfig "~/.ssh/config")))
> ;;; per Michael Albinus @
> ;;;
> ;;; for problem starting R from tramp file buffer
> (add-to-list 'tramp-remote-path 'tramp-own-remote-path)

and I can now

Rodney Sparapani Thu, Jan 12, 2012 at 1:09 PM
>>> I just remotely tramp a file. Then, in that buffer do a M-x R
>>> For me, that opens a remote R session; no ssh.el required.

and when I run

> system('hostname')

from buffer=*R*, I get the expected results--which is great! (Until I
hit the next problem, but that's another thread. Let's end this one
"on a note of triumph" :-)

FWIW I believe the "lessons learned" from this experience are

1 Since tramp has been part of emacs (and xemacs, IIRC) for several
  years, ESS should update its docs (e.g.

  ) to reflect

- that ssh.el is no longer needed
- how to use tramp instead

2 The tramp folks will fix the tramp-remote-path bug soonest; meanwhile
  there is a simple workaround.

thanks all, Tom Roche <address@hidden>

reply via email to

[Prev in Thread] Current Thread [Next in Thread]