[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: sftp access failure (again)

From: Stephen Berman
Subject: Re: sftp access failure (again)
Date: Thu, 10 Feb 2022 11:35:50 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/29.0.50 (gnu/linux)

On Thu, 10 Feb 2022 10:32:49 +0100 Michael Albinus <> 

> Stephen Berman <> writes:
>> Hi Michael,
> Hi Stephen,
>> I'm unable to access a remote site via sftp using Tramp.  It's the same
>> site I've had Tramp problems with several time over the last few years
>> -- and each time you've been able to fix the problem, so I'm hoping that
>> happens now too!  The site administrators have recently restricted
>> external access to the site via VPN tunnel only, and this works for me
>> with sftp from shell, but with Tramp I get "tramp-handle-access-file (1)
>> # Cannot access file or directory: Reading directory: Permission
>> denied".  The directory in question is three levels down, and I can
>> access the two higher levels via Tramp, only the third level (which is
>> where my personal data is) is inaccessible.  One difference between
>> using sftp in the shell and using Tramp is that with the former, I
>> explicitly enter my password, while Tramp accesses my password from my
>> ~/.authinfo file.  I've attached a gzipped level 6 Tramp debug trace.
> Yep, in the trace file there is
> 20:35:24.603530 tramp-handle-access-file (1) # Cannot access file or 
> directory: Reading directory: Permission denied, 
> /
> Handling the password differently doesn't matter.
> It isn't completely clear to me why this happened. But I have a
> suspicion. The file information of that directory are
> bermasbp      7       (directory)     standard::display-name=bermasbp 
> time::modified=1603836403 time::access=1643996815 unix::mode=17896 
> unix::uid=45845 unix::gid=33
> Mode 17896 corresponds to "drwxr-s---", that means the setgid bit is
> set. Tramp doesn't handle setuid and setgid properly I believe. Could
> you please check the appended patch, whether it helps?

I applied the patch and rebuilt, cleared all Tramp connections,
restarted Emacs, activated the VPN tunnel and tried to access the
remoted directory, but got the same error.  I've attached a gzipped
verbosity level 10 trace.

Steve Berman

Attachment: tramp-debug3.gz
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]