[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: sftp access failure (again)

From: Michael Albinus
Subject: Re: sftp access failure (again)
Date: Thu, 10 Feb 2022 13:31:17 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/29.0.50 (gnu/linux)

Stephen Berman <> writes:

Hi Stephen,

> I applied the patch and rebuilt, cleared all Tramp connections,
> restarted Emacs, activated the VPN tunnel and tried to access the
> remoted directory, but got the same error.  I've attached a gzipped
> verbosity level 10 trace.

Thanks. The problem is more difficult. Tramp believes that the remote
uid/gid is 0 (which is the value of the root location "/"). Because of
this, Tramp regards file modes "drwxr-s---" of directory "/b/bermasbp/"
as unreadable, because this directory is owned by "unix::uid=45845" and

I've prepared another patch (appended), which makes the check
weaker. Could you, pls, test?

> Steve Berman

Best regards, Michael.

Attachment: txtr0IoHuf2P8.txt
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]