[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [XForms] New pre-release xforms-1.0.93pre1

From: Jens Thoms Toerring
Subject: Re: [XForms] New pre-release xforms-1.0.93pre1
Date: Tue, 22 Dec 2009 18:42:00 +0100
User-agent: Mutt/1.5.18 (2008-05-17)


On Tue, Dec 22, 2009 at 05:55:16PM +0100, LukenShiro wrote:
> I want to point out some other bugs (sorry if they are somehow
> "nibbles" :P).
> 1) The description above fl_popup_set_min_width function
> (lib/popup.c:2169) is the same as fl_popup_get_min_width:
>  Get -> Set

Thanks for spotting that, stupid me!

> 2) (not a real bug, but ...)
> fl_get_pixmap_pixmap (lib/pixmap.c:579) has a redundant return value
> (maybe not necessary as *p is already defined in place?):
>     *p = sp->pixmap;
>     if ( m )
>         *m = sp->mask;
>     return sp->pixmap;

You're completely right. On the other hand that is what the
documentation has been promising to be the public interface
for a long time and I try not to change that unless for very
good reason since some programs out there (unlikely as it
may be) might be depending on the behaviour (I have already
broken enough programs of other people by not being careful

> 3) AFAIK fl_winstepsize doesn't exist anymore, but it is currently
> explained in documentation:
> doc/part5_useful_functions.texi:287: @findex fl_winstepsize()
> doc/part5_useful_functions.texi:288: @anchor{fl_winstepsize()}
> doc/part5_useful_functions.texi:290: void fl_winstepsize(Window win, int
> xunit, int yunit);
> doc/xforms.info:1233: Ref: fl_winstepsize()743642
> doc/xforms.info-3:2987:  void fl_winstepsize(Window win, int xunit,
> int yunit);
> doc/xforms-info-4:1358: * fl_winstepsize(): Windowing Support. (line
> 127)
> I'd guess it has been replaced by fl_winstepunit (lib/win.c:243).

Yes, that's another one where I think it would be useful to
use the real function name instead of an alias - only in that
case the aliased name sounds better to me than the original
one (fl_winstepunit()) since my association when I read "unit"
is that it's about points, mm etc. instead of the number of
pixels the window size can be changed. So in this case it would
seem better to me to rename the function to fl_winstepsize()
(still a bit ackward) and keep the original name only as an
alias (and the documentation can stay as it is;-) Do you have
any objections?

Thank you very much, it's very reassuring to know that some-
one else is going over the sources with a fine comb! Please
keep up the good work;-)

My best wishes to you as well as all the others here on the
mailing list for the coming holidays (I hope you have some!)
and a very happy and successul new year!

                              Best regards, Jens
  \   Jens Thoms Toerring  ________      address@hidden
   \_______________________________      http://toerring.de

reply via email to

[Prev in Thread] Current Thread [Next in Thread]