[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[XForms] XForms failure after upgrading to Fedora 19

From: davidwriter
Subject: [XForms] XForms failure after upgrading to Fedora 19
Date: Sat, 11 Jan 2014 19:06:07 -0800
User-agent: KMail/4.11.5 (Linux/3.12.6-200.fc19.x86_64; KDE/4.11.5; x86_64; ; )

I recently upgraded my Linux system to Fedora 19 from Fedora 17 (64 bit OS in 
both cases). All programs seemed to compile and function properly after the 
upgrade, BUT this was not the case - an important program based on XForms 
failed when any user other than myself (I'm system administrator, but my id 
has no special privileges like being a sudoer) used it. It had previously 
worked perfectly in Fedora 17 (Because of some of the operations it does it 
cannot run as root).

I investigated this and found that when the program reached a fl_do_forms() 
statement it would flash momentarily on the screen and then close. 

I then decided to do a test - I tried a simple program:
#include <forms.h>

int main(int argc, char **argv)
   FL_FORM *form;

   fl_initialize(&argc, argv, 0, 0, 0);

   form = fl_bgn_form(FL_UP_BOX, 230, 100);
   fl_add_button(FL_NORMAL_BUTTON, 20, 20, 190, 60, "Hello world");  

   fl_show_form(form, FL_PLACE_MOUSE, FL_FULLBORDER, "Hello, world!");

   return 0;

Once again, I found that any user other than myself or root would have that 
program fail - it would flash onto the screen and then disappear 
I seem to be not the only one with problem - a post in FedoraForum.org on Jan 

>pburk                                             Join Date: Jan 2014
>                                                      Location: Tartu,Estonia
>libforms and Fedora 20

>Has anybody succeeded in using xforms library (libforms) under Fedora 20? It 
>seems that under my standard installation something has went wrong as I am 
>not able to run any program (including demos) which includes fl_do_forms() 
>function - the programs draws the form(s) correctly (can be best seen with 
>debugger), but fl_do_forms() does not wait for any interaction but just 

>Best regards and TIA,

The solution offered by another user was to put a while loop to trap 
fl_do_forms() :
   while ((all = fl_do_forms()) != ok)
      /* empty */ ;
which works, but is neither a feasible nor a satisfactory solution for my 

All programs were compiled using gcc and the  1.0.94-0.9.pre17.fc19.rpm from 
Fedora (although the library appears as libforms.so.2.0.0 in /usr/lib64). The 
systems all use nVidia graphics cards which have the latest drivers.

I'm stumped - any ideas what might be happening?

David Scriven   

reply via email to

[Prev in Thread] Current Thread [Next in Thread]