[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX-devel] problems with xemacs 21.5.28

From: Artemio Gonzalez Lopez
Subject: Re: [AUCTeX-devel] problems with xemacs 21.5.28
Date: Wed, 23 May 2007 12:05:06 +0200

On May 23, 2007, at 7:54 AM, Ralf Angeli wrote:

* Artemio Gonzalez Lopez (2007-05-23) writes:

The latest CVS auctex doesn't work well with the latest CVS xemacs
(21.5.28) for me. More specifically, I'm having the following problems:

1) Syntax hilighting is broken. When I open a tex document, I get the
following error message in the status bar:

itimer "lazy shot for foo.tex" signaled: (wrong-type-argument
number-char-or-marker-p nil)

I cannot reproduce this with XEmacs 21.4 or CVS XEmacs (about a month

My problem is with the latest xemacs (21.5.28), of a few days ago

Do you have any customizations related to font locking, e.g. in

I only have

'(TeX-install-font-lock 'font-latex-setup)


'(lazy-shot-mode t nil (lazy-shot))

Ideally, please make a
self-contained testcase exhibiting the problem and starting with
xemacs -q -no-site-file

I've tried that, and I still get the error

Wrong type argument: number-char-or-marker-p, nil

as soon as I select "Lazy Shot" in the "Syntax Highlighting" menu (since otherwise the document is not fontified)



reply via email to

[Prev in Thread] Current Thread [Next in Thread]