[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] Trouble with Find Documentation

From: Ralf Angeli
Subject: Re: [AUCTeX] Trouble with Find Documentation
Date: Wed, 28 Jun 2006 00:29:59 +0200

* Alan Ristow (2006-06-27) writes:

> The one problem I'm having with both right now is the Find Documentation 
> command. When I run it from Emacs, it prompts me for a command or 
> package name. I've tried typing a number of packages that I know are 
> installed on my system -- memoir, textcomp, etc. -- but it always 
> responds with "Documentation not found." I've checked the value of 
> TeX-Macro-Global and it contains the proper paths to my TeX installation.

What appears if you copy the lines

(when (executable-find "texdoc")
                (TeX-search-files nil '("dvi" "pdf" "ps" "txt" "html") t t))

into the *scratch* buffer, place the cursor behind the last
parenthesis and type `C-j'?

> When I run it from XEmacs, I get an error reading "Autoloading failed to 
> define function Info-find-file." After a little googling, I get the 
> impression that this particular feature is broken under XEmacs for the 
> moment. Is that correct?

Yes.  The situation with the CVS version of AUCTeX is a bit better.
It does not throw an error, but getting documentation of LaTeX
commands from does not and probably will not work with
XEmacs and Emacs 21.  Getting documentation via texdoc should work in
all Emacs and XEmacs versions, however.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]